Please help me upgrade to Yosemite

Discussion in 'OS X Yosemite (10.10)' started by uscpsycho, Mar 20, 2015.

  1. uscpsycho macrumors newbie

    Joined:
    Mar 15, 2009
    #1
    I am running 10.7.5 and need to upgrade to Yosemite so I can run software that won't run on 10.7.5.

    I have downloaded it multiple times and every time I try to install it I get this error: "This copy of the Install OS X Yosemite application can’t be verified. It may have been corrupted or tampered with during downloading."

    I have searched and searched for answers. The thing that works the majority of the time is making sure the system date is correct and changing DNS to Google. All along, my date was right and my DNS were set to Google, so there is nothing to change.

    According to Apple t is not necessary, but I considered an intermediate upgrade to Mavericks first. Problem is you can't get that from the app store anymore so I can't try that.

    I'm not willing to do a clean install. Too much data to lose and it's such a PITA to start over with no apps, etc. Please don't suggest the nuclear option.

    Anything else people can suggest? Please help! This is beyond frustrating and sooooo many people have the exact same problem. How does Apple screw this up so badly?

    This is on a 15" early 2011 MBP.

    TIA
     
  2. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #2
    One thing that might help, create a new admin user, reboot and login as the new admin user. I would also suggest repairing permissions. Now try downloading Yosemite. Make sure to backup your data before you install Yosemite.
     
  3. uscpsycho thread starter macrumors newbie

    Joined:
    Mar 15, 2009
    #3
    Negative. Same exact problem. Thanks for the suggestions.

    I also tried creating a Yosemite install drive and booting from that. Same result.

    Any other suggestions would be greatly appreciated.

    I have to say, as someone who spent a lot of years in the Windows world, OSX has fewer issues in general but they tend to be way more challenging to resolve. And they're often baffling, for instance the error I am getting is clearly not the cause of the problem.
     
  4. uscpsycho, Mar 20, 2015
    Last edited: Mar 20, 2015

    uscpsycho thread starter macrumors newbie

    Joined:
    Mar 15, 2009
    #4
    Here's a rundown of everything I have tried so far:

    I tried re-downloading. I tried rebooting. I checked the date. I checked the DNS. I verified the hard drive. I checked permissions. I repaired the hard drive. I tried installing from the App Store. I tried creating a Yosemite install disk and booting from that to install. I tried creating a new virgin admin account and installing from there. I reset the SMC. I reset the PRAM.

    End result was the same every time. Come on Apple. You're better than that. So I thought.

    For the record, there is nothing wrong with my Mac that I can tell. Works fine. Only motivation I have for upgrading is that more and more applications require 10.8 or above. And I have an app I need to use now that requires 10.9. I have no idea how I'm going to ever use it if the upgrade digs its heels in like this and refuses to install.
     
  5. kernowRE macrumors newbie

    Joined:
    Feb 7, 2015
    Location:
    Scotland
    #5
    I realise this doesn't 'solve' the problem, but as a workaround could you not get someone else with a mac to use disk maker x and make a usb install disk for you?

    also, are you completely erasing the hard drive before trying to install? my friend had an older macbook and i had to wipe it to get it to accept yosemite. you could migrate from a time machine backup afterwards to restore apps etc.
     

Share This Page