Please help me with export/sharing settings in imovie 09

Discussion in 'Digital Video' started by Pawleys Island, Apr 18, 2009.

  1. Pawleys Island macrumors newbie

    Joined:
    Apr 18, 2009
    #1
    I have shot some HD footage and edited it in 09 imovie. Footage was imported at 1920x1080.

    I have made several attempts to export/render at high resolution for use in a keynote presentation, but without success. The video skips and it's quality has been changed for the worse..

    I did this last year on an older version of Imovie with success, so this is driving me crazy as to why it's doing what it's doing.

    I have tried to export simply to media files sharing, but the limitation there is 720 instead of 1080 and the video still does not look too good.

    I tried to export using quicktime and have messed with the H.264 and MPEG-4 improved but in both cases after several hours of rendering, it turned out bad..

    It's a 10 minute clip and I'm projecting it on a 14' screen via a keynote presentation... and it's quality looks great on the imovie preview screen..

    Thanks in advance to anyone who can help me,

    Best,

    Rob
     
  2. huntercr macrumors 65816

    Joined:
    Jun 6, 2006
    #2
    If you're just wanting to show it from the computer, and just want high performance and don't care about the harddrive space it takes up, I would suggest rendering it as a Quicktime movie with Apple Intermediate Codec. This will result in a very large file compared to H.264, but it will take lower CPU power to show in your presentation and will be very high quality.
     
  3. Pawleys Island thread starter macrumors newbie

    Joined:
    Apr 18, 2009
    #3
    Thanks for the help!

    I will try that now!

    Rob
     
  4. Pawleys Island thread starter macrumors newbie

    Joined:
    Apr 18, 2009
    #4
    HunterCR,

    It's stills stepping along a little bit, although it's a lot better.

    Here's what settings I chose. Do you see anything wrong?

    Apple Intermediate Codec
    Frame Rate- current
    compressor preset - other
    Export file settings-
    hd 1920 x 1080 16:9
    (and) the prepare for internet streaming box was checked... (maybe that's the problem?)
     
  5. huntercr macrumors 65816

    Joined:
    Jun 6, 2006
    #5

    Do you have Leopard?
    What model computer are you playing this on?
    How much memory do you have?

    Seems like you're CPU bound here... do you have your system preferences->Energy Saver->Options Processor Performance set to "Highest"?

    The latest problem may be in Keynote. How well does it play in Quicktime by itself?

    An alternative, if you don't mind taking up even *more* harddrive space.

    Apple Pixlet codec with "Best" quality or Motion JPEG B on "Best" quality ,
    Pixlet, I recently began experimenting with. It requires tremendously less CPU power to decode. Same thing with MJPEG. Both of these codecs store only "I" frames, which is there is no interpolation between frames. For you thta is good because it takes less CPU power.

    Pixlet compresses better than MJPEG, but compression artifacts are a little more "smeary" rather than "squarey" as with jpeg. If you put it on "Best" you probably won't notice either of them. Try it and see.

    Neither one of these codecs should you use to give to anyone else, but for the presentation it will be really good.
     
  6. Pawleys Island thread starter macrumors newbie

    Joined:
    Apr 18, 2009
    #6
    I've got the new 17" mbpro

    Thanks for the help! I think the energy saver was most if not all of the problem..

    I might try your other suggestion since I have some room right now just as a comparison..

    I appreciate your help!


    Rob
     
  7. huntercr macrumors 65816

    Joined:
    Jun 6, 2006
    #7
    Awesome. Still if you have the lastest MBP, I'm honestly shocked it wasn't keeping up. Especially since I assume you have Leopard. You really should be kicking but with 1080i/p decoding with that sort of horsepower. My Dual G5 1.8GHz struggles somewhat, but you've got at least 4x the CPU speed of me.
     

Share This Page