Please Help Me!! Zip Instead Of Ipsw

Discussion in 'iPod touch' started by dmlskatensnow, Nov 30, 2007.

  1. dmlskatensnow macrumors newbie

    Nov 30, 2007
    Ok guys, I'm new here because I need a lot of help on downgrading my ipod from 1.1.2 to 1.1.1. I have found countless numbers of great tutorials as how to go about doing this but everytime I try to download a file that is ipsw I ALWAYS DOWNLOAD IT AS ZIP! Ahhhh, please help me because this makes it impossible for me to downgrade. Thank you!:)
  2. xXriderXx7 macrumors 6502a


    Jul 6, 2007
    Lake Elsinore, California
  3. Shadow%20Mac macrumors demi-god

    Dec 28, 2007

    I have the same problem with the ZIP. No, changing the extension to .ipsw does NOT work. please help who ever can!
  4. Shadow%20Mac macrumors demi-god

    Dec 28, 2007
    Still need help, thanks, though

    Ok, i clicked on the link, but...

    at first, it appears as a .ipsw file in safari's download list.
    Then, it changes to a zip file.
    When i unzip it. it becomes a folder.:confused:
  5. native00 macrumors regular


    Mar 26, 2004
    San Diego
    This problem happened to me, her's what you do...

    Go into Safari>Preferences>General.

    On the bottom third of the screen you will see a box that says something like "Open safe files automatically". Uncheck it.

    Then, download the package again, and this time it will not unzip by itself.

    Erase the .zip part of the file extension, and voila - it will work.
  6. Shadow%20Mac macrumors demi-god

    Dec 28, 2007
    Ok Figured It Out

    1. Launch Safari
    2. Press Command and , (or click safari>preferences)
    3. Go to "General"
    4. Uncheck "open 'safe' files after downloading"
    5. Download 1.1.1 from the link above (Curtsey of CactusChef)
    6. You should still get a zip file, though it will not unzip itself. DO NOY UNZIP.
    7. the file should end with ""
    8. Delete the ".zip"
    9. An alert should appear. Click "use .ipsw"
    10. The file should look like a lego brick with pictures on it.
    11. Move the file to the desktop
    12. Plug in iPod Touch
    13. option-click update, and choose the file on the desktop
    14. wait till iTunes install 1.1.1 (can take up to 5 minutes)
    15. navigate to on your iPod
    16. Click "Install AppSnapp"
    17. Wait till you see the "slide to unlock screen"
    18. You should see "Installer 3" on the iPod home screen.

    :) works for me
  7. Maegulimavri macrumors newbie

    Nov 17, 2007
    I was having similar problems about a month ago as well.

    Initially i tried something similar to your method Shadow, but simpler — i just, after downloading the file with safari and after Safari automatically extracted/unzipped the 1.1.1 file for me, compressed in again using OS X's in built software. The file took on the form that it is supposed to have for a downgrade (i may have needed to alter its file name as Shadow's method also requires - can't remember now, but as i explain later, that doesn't matter) and by all accounts the downgrade should have worked using this file.

    Unfortunately i got the same error from iTunes. I went away for a month and thought to myself maybe i should just not use Safari at all (plus i think I read a post from these forums (or fora) recommending as such at some point, though i ignored it initially) — i then downloaded the 1.1.1 firmware using firefox, and the downgrade went without a hitch.

    Shadow, your method probably achieves the same end — just thought i would add that for those having troubles and are using safari, try firefox (just this once as despite this post i am a safari advocate).

    Anyone have anythoughts as to why my initial method of compresseing the firmware after safari's auto-extraction didn't work — theoretically shouldn't the reversal of an extraction, that is, a re-compression yield the same file as that which was extracted/de-compressed. ie, what is it about Apples software that impeded what should have been a simple affair? Coincidental that it happened to impede piracy against another Apple device?

  8. Chuckypool macrumors member

    Aug 22, 2007
    Auckland, New Zealand
    I had similar problems when I downloaded the file using Safari, but when I used Firefox it worked fine. No problems.

  9. Shadow%20Mac macrumors demi-god

    Dec 28, 2007
    The Answer...

    Firefox works because Apple's Safari has had a bad habbit of compressing large files since 2.0, which came bundled with Tiger. Safari 3.0 also retains this bad habbit. You can disable through the system preferences, or download the iPod firmware through firefox. Both methods worked for me! The other fault of Safari is that it thinks it knows what files are safe, and what files are not safe. The default setting is to automatically open/unzip "safe" files. This can also be changed through Safari's Preferences.
  10. helical macrumors member


    Nov 1, 2008
    sorry to bump this thread, but this saved my ass today

    well not my ass, but my iPod touch's at least, which in turn makes a big difference to me
  11. matthew84 macrumors newbie

    Dec 14, 2008
    sorry to bump but,

    is there a way to change it so it doesnt automatically add .zip to the end?

Share This Page