PLEASE HELP!! My Dock and Expose do not work on my MacBook Pro...

Discussion in 'MacBook Pro' started by chks, Aug 29, 2014.

  1. chks macrumors newbie

    Joined:
    Aug 29, 2014
    #1
    Hello,

    I've been having issues with my MacBook Pro/Mac OS X (10.6.8) and I need some help immediately.

    The current issues are:
    - My Dock doesn't show up on desktop
    - My Expose doesn't work
    - When I tried to minimise opened page it freezes (I can still force quit the programme)
    - Some function of searching in finder is behaving funny.

    What I can think of I've done wrong in past hours:
    - I tried to install Winebottler as I wanted to open win.exe file for my work
    - I did install them and opened them, from Winebottoler I tried to install 'Windows Media Player 10'
    - It automatically started to installing but during that computer started to behave funny
    - So I tried to uninstall Wine and Winebottler from Application, deleted them and empty the trash
    - Still having the same issues so I went Application folder to see if there's any Windows related app left that I just installed.
    - When I scroll down to the bottom, the finder closes it self off and reopen Application folder! (Refresh itself)
    - Also when I try to search 'windows media player', or anything like 'windows' on the finder it closes itself and it doesn't let me search it. I can still search other stuff, it is just so strange.

    Is this some kind of bug? I thought Mac wouldn't get virus but maybe I was wrong?
    Tried to turn the computer on and off again, or restart, or relaunch the finder, it just doesn't work.
    My friend told me to use Time Machine but I've never used it so that means nothing had been backed up from previous settings?

    I need to fix this ASAP so please give me any solutions if you think of any.

    Thank you! :(
     
  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #2
    Reinstall OSX, if that doesn't restore normal function then a format and fresh install will. You don't have a virus.
     

Share This Page