Please help my G4 get some sleep

Discussion in 'Mac Basics and Help' started by alangyssler, Aug 9, 2005.

  1. alangyssler macrumors member


    Mar 5, 2005
    Buffalo Grove, IL
    I know people have asked about this in the forums, but I've not found any replies that lead to a solution... so I guess this is a bump for several threads simultaneously... please help me! It's driving me nuts!

    I've had this problem for well over a year now with my QuickSilver G4 (733 - 2001 model), leading me to believe it's not a problem incurred from recent OS updates... for the record, I'm running 10.4.2

    All the following didn't help me obtain sleep for more than a few seconds...
    I've disconnected everything. I tried pressing that little black button on the mobo for 15 seconds, or so. I zapped the PRAM, and did that thing in the open firmware to reset the PMU. I tried removing all additional RAM, and putting back the original 40 gig hd. I tried wiping everything, and just installing a fresh copy of the OS. I tried repairing permissions more times that I can count. I tried removing the two USB cards that I added in, and running without them. No sleep. I tried putting on a 7 port hub for all my periphs, and disconnecting it when I wanted it to sleep. Tried replacing the battery inside the case, and still no luck. I've tried just about everything I can think of... and still NO SLEEP for my Quicksilver 733 (2001)

    My computer has the preferences unchecked for waking from sleep automatically. Still no luck.Nothing screwy going on in the Activity Viewer, either. From what I can tell, that is...

    By not sleeping, I mean I can select "sleep" from the Apple menu, and everything will power down, but them within seconds, it comes back to life.

    I HAVE maintained sleep for several hours when running my computer from a Firewire external HD with OS 10.3.9 on it. But why would that work when nothing else has? Please help. I hate haiving to turn my computer off at the end of the day so that it won't wake up in the middle of the night, and subsequently wake me up.

    My setup is the G4 QuickSilver 733 (2001 model)
    768 Ram
    2- 120 GB drives
    Pioneer DVD Burner
    Internal 250 mg zip drive
    4 port USB 2.0 card
    no other additions inside the case

    outside the case:
    apple keyboard
    microsoft 5 button mouse
    griffin powermate
    m-audio usb quattro (usually off)
    prolific external case (usb + firewire) with a 200gb drive - using usb (usually off)
    canon scanner

    please help!
  2. hcuar macrumors 65816


    Jul 23, 2004
    I've had USB devices wake up my PM before. If my printer goes to "sleep" or wakes up, my PM wakes up. I would image that other devices could do the same. I'd recommend removing all devices other than keyboard and mouse and giving that a try. I also believe that ethernet activity could wake the machine.
  3. CoMpX macrumors 65816


    Jun 29, 2005
    New Jersey
    Not to be rude, but he just went through saying that he disconnected EVERYTHING already.

    After telling us all of the things that you have tried, I honestly cannot think of anything else but to give Apple a call, if you have not tried that already. You probably did, but I can't think of anything else. I'm totally stumped on this one. :confused:
  4. alangyssler thread starter macrumors member


    Mar 5, 2005
    Buffalo Grove, IL
    Thanks for your quick response! I've tried disconnecting everything except for the keyboard and mouse, and have had the same results. Also, I have the "Wake on" boxes unchecked in the energy preferences.

    What boggles me the most is that, when using my external firewire drive running 10.3.9 as my boot disk, my G4 can sleep without any problems, as far as I've seen. Any idea why this might be?

    My biggest beef is that I can't stand having to shut down at night, and start up in the morning. I suppose I could set the timer to shut down for me, and start up again for me, too.... but I want my computer to act the way it SHOULD be, not have to accomodate it's insomnia. I'll try doing this again tonight, and post results. Are there any other open firmware things to try?

    I suppose I should put everything back in that it came with when I bought it, and reinstall the OS, and try making it as similar to the "out of the box" status that I got it in, but that's a tremendous amount of fiddling around inside, and I don't know if it will get me anywhere. Something to consider, though.

Share This Page