PLEASE help my Mac recognize my hard drive!

Discussion in 'macOS' started by Zwhaler, Feb 18, 2008.

  1. Zwhaler macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #1
    External hard drive, that is. My Time Machine disk does not show up on my desktop or under "devices" when I plug it in and turn it on. Why? I need it to back up 3 Mac computers, so please help! This is a USB drive.
     
  2. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #2
    Are these other two computers Windows PCs?

    If you so, you probably have the hard drive formatting using the NTFS file system. Macs are supposed to be able to read but NOT write to NTFS drives.

    What does Disk Utility on the Mac say about this drive when it's plugged in?
     
  3. Zwhaler thread starter macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #3
    Nope, the HD has been fine until I came back from my 3 week trip about 2 days ago. Until the day I left, I was using it daily to back up my machine. Yes the PCs are windows, but the disk doesn't even show up in disk utility when it is plugged in and turned on, nor does it appear on my desktop at all.

    edit: read post #4
     
  4. Zwhaler thread starter macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #4
    Ok, I know nobody cares, but if anyone of you out there knows what to do in this situation, please let me know. Every time I try to verify or repair disk in disk utility (the HD shows up on the sidebar) it says "Failed" in red letters before it finishes. I'm pretty sure that my friend voided the warranty when he disabled the annoying blue lights on the front for me, so is there anything I can do? I would like to get it working and sell it or get it replaced, because I want to buy time capsule as soon as it comes out.

    I have also rechecked to see if this thing works with a PC, and the PC recognizes it as a hi-speed USB mass storage device, and under "status" it says that it works fine, except it won't appear under "My Computer" where it should and I cannot access it's contents.
     
  5. John01021988 macrumors 6502

    Joined:
    May 11, 2007
    #5
    what format are you using....
    NFTS is NOT recognized by OS X, FAT 32 and Mac Journaled are the ones you need (Mac Journaled for Time Machine) Try to back up everything inside ur HD, then make 2 partitions, one NFTS or FAT 32 and the other one Mac Journaled for Time Machine usage.
     
  6. Zwhaler thread starter macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #6
    My Filesystem is Mac OS Extended, and it says Case Sensitive also.

    Heres everything Disk Utility will tell me. First aid fails every time

    Name : Time Machine Backups
    Type : Volume

    Disk Identifier : disk1s1
    Mount Point : Not mounted
    File System : Mac OS Extended (Case-sensitive, Journaled)
    Connection Bus : USB
    Device Tree : /PCI0@0/USB7@1D,7/@4:1
    Writable : Yes
    Universal Unique Identifier : 820637A6-ADD2-35E3-A7F8-46DF23C00E60
    Capacity : 465.8 GB (500,105,217,024 Bytes)
    Owners Enabled : No
    Can Turn Owners Off : Yes
    Can Be Formatted : Yes
    Bootable : Yes
    Supports Journaling : Yes
    Journaled : No
    Disk Number : 1
    Partition Number : 1
     
  7. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #7
    Is there any more specific information on the failure when you attempt to run First Aid?

    All I can tell you is that I once had my 500GB Firewire external so thoroughly hosed by Time Machine (it's gotten MUCH better since 10.5.2) that I had a similar situation. No amount of black magic could get Disk Utility to repair it so I eventually turned to DiskWarrior. That worked for me.

    You might also try running fsck in terminal to see the specific error you're getting.
     
  8. Zwhaler thread starter macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #8
    Here ya go, it doesn't look good :( This was when I attempted to verify disk.

    Verifying volume “Time Machine Backups”
    Checking Journaled HFS Plus volume.
    Detected a case-sensitive catalog.
    Checking Extents Overflow file.
    Checking Catalog file.
    Checking multi-linked files.
    Checking Catalog hierarchy.
    Checking Extended Attributes file.
    Invalid node structure
    Volume check failed.

    Error: Filesystem verify or repair failed.

    ---------------------
    note: the last 3 lines ("invalid node structure" to the bottom) are all in red
     
  9. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #9
    Sorry to hear that because that is precisely the error I was experiencing. Your mileage may vary of course but if the lost data is that critical to you there is a good chance DiskWarrior can succeed in fixing it where fsck failed.

    In my case it was a catastrophic write error caused when I inadvertently powered off my external while Time Machine was writing to it. :(

    Good luck.
     
  10. Zwhaler thread starter macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #10
    Shoot, that wasn't what I was hoping for but kind of what I was expecting :(
    The data on the drive isn't critical to me, my main concern is that I now have no method of backing up data for 3 computers. I'd rather not go the DiskWarrior route, because the damn drive only cost 40 dollars more than the DW software, so I guess I'll just suck it up and take the whole thing as a loss. I just wish Apple would have released Time Capsule along with Leopard, that would have saved me (and many others I assume) this hassle. Thanks to everyone who helped, I now lay this thread to rest :p
     
  11. TJones macrumors regular

    Joined:
    Feb 11, 2008
    #11
    What brand model is it and have you checked the manufacturer's site for disk utilities that will perform a advanced diagnostic.
     
  12. BornAgainMac macrumors 603

    BornAgainMac

    Joined:
    Feb 4, 2004
    Location:
    Florida Resident
  13. Zwhaler thread starter macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #13
    It is a 500GB IOmega drive, and after checking their website, I believe that I am out of luck. They offer data recovery, which is not what I am looking for.

    I just tried and it wouldn't let me format it as Mac OS Extended Journaled.
     
  14. MoncoZero macrumors member

    Joined:
    Jun 26, 2007
    Location:
    tv land
    #14
    I read the whole post, but as I am not a computer guy I did not understand a lot of the stuff in the middle. So why reply?

    I was using a firewire connection from computer to external hard drive that worked fine. Later after returning from a 3 week vacation my computer would no longer recognize the hard drive.

    Eventually I tried connecting the hard drive with a USB cord. Now it works.

    That's the extent of my advice, good luck.
     
  15. TJones macrumors regular

    Joined:
    Feb 11, 2008
    #15

    IOmega and the like usually put in drives from other manufacturers like Western Digital or Seagate. I'd be tempted to install Seatools for Windows from the Seagate web site and plug in the drive into a Windows machine and see what drive model the tool spits out for it. It might just be a Seagate after all or at worst you could go digging through WD's site for their Data Lifeguard Tools for Windows.

    In any case I wouldn't trust that drive for anything until you get a clean bill of health. The only thing worst than not having a backup is having a backup that doesn't work :(
     
  16. codemancmc macrumors newbie

    Joined:
    Jan 23, 2008
    #16
    I had a similar issue where the file structure became corrupt.

    Try a partitioning software for Windows like Partition Commander.

    It can force repair of the file system back to DOS-Based NTFS and replace all data sectors with 0's like the drive is new.

    Then connect it to your mac and partition as suggested above, 1 Mac OS (journaled) and 1 Fat32 or NTFS for your Windows Backups.

    Of course this is assuming your hard drive itself isn't damaged.

    Hope this helps!
     
  17. Zwhaler thread starter macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #17
    I apologize, I have made some changes to my post to help clear up some issues.

    From late october until January 26th, I was using the 500GB USB External Hard drive to back up 3 macs with Time Machine. When I came back from my trip on february 17th, none of my macs (or a laptop PC that I tested) would mount the hard drive or let me access it's contents. The Hard Drive would not show up on my desktop, however, I have got it to appear on the sidebar in Disk Utility.
    Any attempt to Verify or Repair disk (on the external HD) have failed. I posted the error message it gave me in post #8.
    The HD is formatted using Mac OS Extended, case sensitive, and journaled. I do know that I have not formatted it since it was last working properly with time machine about a month ago.
    Hope that helped :eek:


    another edit: I have tried erasing and formatting the disk using Disk Utility, except when I selected "Don't erase data", it said that an error occured and that the "resource is busy". When I tried "zero out data", it said there was an error and that it could not open the disk. This was when I tried to format the disk as Mac OS Extended (Journaled). Should I try something else?
     
  18. TJones macrumors regular

    Joined:
    Feb 11, 2008
    #18
    Well, if you know the warranty is voided and there's nothing else to be done you could crack the enclosure open and extract the disk, plug it into a Windows box, format it and check to see if at least the drive is still useful.

    There are some external hard drive USB enclosures that go for around 20-25 dollars if that gives you any ideas. :) I don't know what your comfort level is for doing any of that but maybe you could recruit your buddy that "turned off the lights" for you. Otherwise I think you have a brick on your hands and could someday be useful in fending off an assailant :p
     
  19. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #19

    I have to apologize as well. I was misunderstanding your situation. I see that it's not a case of you recovering or losing the existing data on the drive but that it won't even let you format it! :eek:

    I would have advised you as the others above that the HD could be removed from the enclosure and stuck into a PC where you could low-level format it with a utility from the drive maker.

    I guess the IOMega is obviously no longer under warranty, right? If so that would obviously be the best route of all.

    Also, I like the advice of the user above who suggested you try hooking it up via USB if you have a connector on the drive. I've actually heard of this working in some cases.
     
  20. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #20
    The poster above recommending you try a Windows partition utility gave me another thought.

    Why don't you try a GParted Linux LiveCD. This is a free Linux application which you burn to make a boot CD that can partition and format disks.

    Download and burn the image then put the CD in your Mac and hold C down while booting up. This should automatically boot you to the LiveCD.

    If Gparted displays your Iomega external it may let you delete the offending partition so that Disk Utility can work with the drive again.

    The current versions don't allow the creation of HFS+ partitions but it can detect and read them and should allow you to remove them.

    Anyway, it's free and worth a try. Just be careful not to work with the external drive and not the Mac's internal HD. ;)

    Gparted -- LiveCD
     

Share This Page