Please help - not allowing iphone to connect through edge

Discussion in 'Jailbreaks and iOS Hacks' started by MacThunder, Apr 7, 2009.

  1. MacThunder macrumors newbie

    MacThunder

    Joined:
    Apr 6, 2009
    Location:
    Croatia
    #1
    Until now i had 2.1 jailbreak version on my iPhone 3G 16gb and now upgraded it to 2.2.1 and jailbreak it. In BossPrefs i cannot longer put the edge to off. I can only put 3g to off and wireless... I just don't want to get a large bill so i want to disable iPhone connecting to the internet via edge and 3g... Please help!

    In help section they sad to try to post here for this...
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Get rid of bosspreffs and install SBsettings.
    Way better utility and it disables thru toggles Edge, 3G, Wifi, SSH and many other things.
     
  3. MacThunder thread starter macrumors newbie

    MacThunder

    Joined:
    Apr 6, 2009
    Location:
    Croatia
    #3
    OK. Now i don't have mossprefs anymore and I have SBsettings... When i click on edge button i turns red but than i turn of my wireless and go to safari, and my iphone loads a page, so edge is working... WTF??
     
  4. MacThunder thread starter macrumors newbie

    MacThunder

    Joined:
    Apr 6, 2009
    Location:
    Croatia
    #4
    Now i restored my iPhone and again quickpwned it and again the same thing... Whe i click on EDGE icon i SBsettings it turns red and then a click refresh and it turn green again... It just wont stay red! This is really frustrating and I'm a bit pissed of... Please help me, I'm out of ideas!
     
  5. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #5
    Forget what other people have said. Use BossPrefs. Way more reliable, and when it says something is off, it is actually off. SBSettings is only if you want to quickly change something, and half the time I turn something off it stays on or crashes my iPhone.

    Once you have BossPrefs re-installed again, there should be a toggle for Edge. If not, go into Config and make sure Show Edge is on. Then go back, and turn off Edge.

    Even when it is off, it will still show a little 'E'. This cannot be helped, but I assure you it is off.
     
  6. MacThunder thread starter macrumors newbie

    MacThunder

    Joined:
    Apr 6, 2009
    Location:
    Croatia
    #6
    OK. I'm gonna do that now. And I know that when it is off that little "E" is shown. It was all fine and working when i had 2.1 on my iPhone. But now when i turn in bossprefs to off i wont go to off...

    Ok. I got bossprefs but it wont turn to off. In bossprefs i click on off and little circle is animating for 3sec and just go back to on... I don't know what I'm gonna do now...
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    Thats weird.
    Theres 2 ways to turn off edge in bosspreffs.
    Did you look further into the settings for the 2nd way to disable it?
    You can always also call your cellphone company and tell them to block all internet data to your line.
     
  8. MacThunder thread starter macrumors newbie

    MacThunder

    Joined:
    Apr 6, 2009
    Location:
    Croatia
    #8
    What is other way in bossprefs... And about calling company, I have T-mobile and I'm in Croatia. They sad when I bought iPhone that there is no way to turn that off...
     
  9. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #9
    If you go into Settings, General, Network, Cellular Data Network, and screw around with the settings... It wont be able to work AT ALL.

    So if you just want to use WiFi, nothing else, this should work.
     
  10. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    Theres also another way of doing it.
    Go to this website in safari on your iPhone
    http://www.unlockit.co.nz/

    Chose Disable Data (FakeAPN)

    It should block data usage until you delete it in your system preferences menu.

    Now if this doesnt do the trick either Im going to fly to Croatia to help you out in person :D
     
  11. MacThunder thread starter macrumors newbie

    MacThunder

    Joined:
    Apr 6, 2009
    Location:
    Croatia
    #11
    It is working, I mean, it is not haha :D I cannot go online without wifi... Thank you a lot! If you come fly to Croatia I'm gonna buy you a bear! ;)
     
  12. SAIRUS macrumors 6502

    Joined:
    Aug 21, 2008
    #13
    Grizzly or Black?

    Panda doesn't count.
     
  13. MacThunder thread starter macrumors newbie

    MacThunder

    Joined:
    Apr 6, 2009
    Location:
    Croatia
    #14
    What? I don't understand this... :eek:
     
  14. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #15
    Same thing on SBSettings. The E still shows.
     
  15. CBR900RR macrumors 6502a

    Joined:
    Oct 11, 2008
    Location:
    Middle of Pacific
    #16
    It work on my SBSETTINGS, I turn off wifi, 3g and than edge and I get no internet connection even it still show "E" next to the AT&T logo.
     

Share This Page