Please Help Powerbook G3 to iMac G5 iSight

Discussion in 'Macintosh Computers' started by Heburnlin, Nov 10, 2005.

  1. Heburnlin macrumors newbie

    Nov 10, 2005
    Hello -

    I was hoping that some of the wise folks here could help me out with a problem. Far too long ago, I bought a first generation G3 powerbook which is currently running on OS 9.1

    I've recently joined the 21st century and bought a (17") iMac G5 iSight - yay!

    I'm having problems moving files from my soon-to-be-retired laptop to the shiny new toy.

    I have installed OS9 on the iMac and initially tried connecting the two by ethernet cable. While they could see each other, they refused to talk with an error message running something along the lines of "Connection to server unexpectedly broken" (I don't remember exactly)

    Calling support they a) informed me that I very likely didn't qualify for support on the G3 (well, no kidding) and that was probably where the problem was - perhaps the ethernet port in the G3 wasn't working properly.

    I've also borrowed from a friend a Firewire PCI card (OrangeLink) which came with drivers a version or two below what the G5 tells me I need (Firewire 2.3.3).

    Does anyone have any suggestions how I might efficiently move most of the files from the G3 to the G5 (short of buying a zip drive and doing it one disk at a time ... not an appealing option)

    Thanks so much,

  2. Will Cheyney macrumors 6502a

    Will Cheyney

    Jul 13, 2005
    United Kingdom
  3. Heburnlin thread starter macrumors newbie

    Nov 10, 2005
    No it does not have a built-in firewire port (or USB)... I bought it just a little bit too early ...

  4. Heburnlin thread starter macrumors newbie

    Nov 10, 2005
    Nevermind -

    In the off chance that someone else has this problem ....

    I took the G3 to an Apple store where one of the resident Mac Geniuses was kind enough to show me how to set up a local network by DNS between the two computers. Apparently there is a communications problem via Appletalk between OS 9.1 and OS X.4

    give each computer an IP (such as and, making certain they are different from one another. with a subnet id:

    Turn filesharing on in the OSX (not the other way 'round), and on the OS9.1, use the chooser, select appletalk, and then type in the ip of the OSX machine. Presto, bingo and I was good to go.

  5. nwrealestate macrumors newbie

    Nov 10, 2005
    Oh yeah thanks I'm in the same situation

    Below is my cry for help on a few different questions. Same type situation as yours, I don't know where to turn on filesharing on the new computer OSX, I thought it was under network but...

    My helper said to turn on filesharing on the old OS9 computer this is still my main computer, printer etc. till I figure out more about OSX. anyhow read below for some of my problems, maybe you could help me with some of this.

    My thead is under 11/11/05 called imac to router or something similiar.

    Still not sure how these threads work - Will try clicking the notify me immediately by email button to keep an I on them.

    ANY HELP is Appreciated:
    See Below;
    Thank you

    Thanks for the help on filesharing, got that turned on and went over to the new imac found network, and my old computer is showing there, wants me to mount volumes but other than the word "volume" there is not anything listed to mount??? Would like to know how to do this but probably won't use it at this time much because old computer applications are compatiable with OS 9.2 and new computer is OSX so I imagine most won't be able to open on OS10.4?

    What I really need to be able to do is access from the imac my printer which hooked up to my old computer. Have tried different things in my desktop utility folder and thought it would work but has not. P.S. does filesharing have to be turned on to do this also? Any suggestions as to how to get this to work??

    Also, sorry so many questions but - 1) I am having trouble accessing my help folders on the new system they are installed but when I go up under help I get a mac help window and try to go to the index but it doesn't go. Don't understand this system 10.4. Have mac 10.4 for dummies coming but in the meantime I'm trying...

    Other problem is setting up safari to check my email which is the same as the one on my older computer - just would like to be able to read it some from the new imac which is located in a different room.

    Guess you didn't know you were opening a can of worms by answering one smally question. If this is too much I understand. I do greatly appreciate your help thus far.

    thank you!!!

Share This Page