Please help: redsn0w quit unexpectedly??

Discussion in 'Jailbreaks and iOS Hacks' started by mtnkingdomgirl, Jan 16, 2012.

  1. mtnkingdomgirl macrumors newbie

    Joined:
    Jan 16, 2012
    #1
    I am trying to JB my iPhone 3Gs using redsn0w 0.9.10b4 and keep getting this error. I open redsn0w, select "Jailbreak", put my phone into DFU mode and when it gets to the point of "Preparing jailbreak data" I get an error that says "redsn0w quit unexpectedly."

    I don't understand why this is happening as I successfully JB this phone last week using Beta 3 (which I also tried today and also gives me the same error). In trying to fix the "No service" error from unlocking, I accidentally restored the phone to factory settings (because I'm a newbie and didn't know how to get out of DFU mode and figured I could just JB it again.) Right now I get the "No SIM Card Installed" message on my home screen, which obviously I can't get past because I don't have a SIM to activate the phone. Can anyone please help?

    ~ Heather
     
  2. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    1. You can manually pick the IPSW and it should go through.

    2. Since you have 3GS, you can downgrade it to 4.1, then hactivate with Redsn0w.
     
  3. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #3
    @OP picking the IPSW manually before jailbreaking will solve your issue.
     
  4. mtnkingdomgirl thread starter macrumors newbie

    Joined:
    Jan 16, 2012
    #4
    Thanks for the responses! Currently downloading the IPSW and will give selecting it manually a try. Fingers crossed ...

    ~ Heather
     
  5. mtnkingdomgirl thread starter macrumors newbie

    Joined:
    Jan 16, 2012
    #5
    Hmmm, update. Downloaded the 5.0.1 IPSW file (iPhone2,1_5.0.1_9A405_Restore) and tried to manually select it in Redsn0W. Got an error saying that my IPSW was not recognized. Have done some research and looks like it might work if I manually select the 5.0 IPSW, so I'm downloading that now. (My internet is slow so it takes a couple of hours.) If anyone has any other thoughts, I'd greatly appreciate it.

    ~ Heather
     
  6. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #6
    You shouldn't have to select 5.0.0, in fact that may cause errors.

    If you cannot successfully jailbreak using the current firmware for YOUR device (verify that if you have an ipsw for a 3GS), using the most recent version of redsn0w, then I would:

    - Delete and redownload redsn0w .9.10b4
    - Delete and redownload ipsw for your 3GS (5.0.1)
    - DFU Restore your iPhone 3GS
    - Restart your computer
    - Reattempt jailbreak
     
  7. mtnkingdomgirl, Jan 17, 2012
    Last edited: Jan 17, 2012

    mtnkingdomgirl thread starter macrumors newbie

    Joined:
    Jan 16, 2012
    #7
    Thanks again for the reply. I did exactly as you said - re-downloaded both redsn0W .9.10.b4 and the ipsw. I tried using it immediately, but it crashed again so I restarted my computer and tried again. This time I tried installing both Cydia and the iPad Baseband and it crashed. So I tried a third time selecting only Install Cydia and it worked!

    HOWEVER, now I want to install the iPad Baseband (so that I can unlock the phone) and I'm getting the same "redsn0w quite unexpectedly" error. I'm using the same ipsw, selected it manually etc. etc. Any new suggestions?

    ~ Heather

    ETA: I checked and I currently have baseband 05.16.05
     
  8. mtnkingdomgirl thread starter macrumors newbie

    Joined:
    Jan 16, 2012
    #8
    Bumping this to the top. Any thoughts out there why it would crash when doing the iPad baseband step?
     

Share This Page