iPhone Please Help :S - Iphone 3GS 6.1.2 jailbreak - (Broken)

Discussion in 'Jailbreaks and iOS Hacks' started by vree, Apr 28, 2013.

  1. vree macrumors member

    Joined:
    Mar 8, 2013
    #1
    Hi It's me again, hope you guys can help me.

    My iphone:
    3GS
    Old bootrom
    6.1.2 jailbreaked with snowbreeze.

    My story:
    So everything was fine (jailbreaked on 6.1.2) untill I installed an app that made me reactivate my iphone. Wich was impossible so I tried to restore it again with snowbreeze custom firmware of 6.1.2.

    First I got error 1600. So I tried different stuff. with tinyumbrella, editing files, ...
    Then I was able to start the restore, even got the snowbreeze logo on iphone.
    But then I got error 14.

    And now it's stuck in recovery loop. So I tried to put it back in powned DFU mode. And restore again. Now I got error 1600.

    So even by some magical way I get past error 1600. Messing arround with tinymbrella and deleting/editing files in C:/Windows/System32/drivers/etc.

    I still get error 1600 and when I do get past it, while restoring I get error 14.

    So is it GAME OVEr for me?

    Also I need to preserve base when upgrading because else I can't make a phonecall. :S

    All help I welcome. And I thank everyone who can help me again.
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    download ifaith (the latest version!). plug in your iphone and click show available caches on server. choose to see what blobs cydia server has for you. save your 6.1.2 shsh blob (i assume you have it, if you don't have 6.1.2 shsh blobs, you CAN NOT restore to 6.1.2) and it'll download and verify it. if it says it is valid, then you can proceed. if it says the shsh is INVALID, then you can NOT restore to 6.1.2 and only to whatever valid shsh blobs you have

    if you don't have any valid shsh blob (iOS 5/6), then you can only restore to 6.1.2 and get a tethered jailbreak if you have the new bootrom (old bootrom can get untethered jailbreak)

    let's leave it at there first and see if you have valid shsh blobs
     
  3. Menneisyys2 macrumors 603

    Joined:
    Jun 7, 2011
    #3
    You can easily downgrade to 5.1.1 from 6.1.2 with the blobs stored in Cydia. I've done the same on my 3GS with the old bootrom (purchased it right on the opening day) after realizing it couldn't run some of my fav tweaks.
     
  4. vree, Apr 28, 2013
    Last edited: Apr 28, 2013

    vree thread starter macrumors member

    Joined:
    Mar 8, 2013
    #4
    Ok got this:

    Just to make things clear I have the old bootrom.
    The ony thing I really care about is being on firmware 6.1.2 and using preserving baseband or I can't make calls. :S

    So I guess this means there is no hope?
    Or what should I do next???
    Phone Is currently in DFU ot connect to itunes mode.
    Can't get anything else to show up after bad restore.

    ALSO, will downgrading with a blob preserve my baseband???

    [​IMG]
    [​IMG]
     
  5. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #5
    On the 3GS with oldboot rom you should be able to untether on 6.1.3
     
  6. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #6
    if you have the old bootrom 3GS, just use ultrasn0w with the 6.1.3 package and make the custom firmware with no baseband upgrade and pwned dfu restore to that firmware. you'll still have an untether jailbreak, if that's what you're concerned about

    you cannot restore to any ios 6 firmware as all the blobs you have for that is invalid. you can however restore to ios 5.0.1, 5.1, and 5.1.1 if you should choose to

    and i would recommend retrieving 6.1.3 shsh blobs and submitting them to cydia's server

    it's entirely dependent on how you restore (the ipsw package used)
     
  7. vree, Apr 28, 2013
    Last edited: Apr 28, 2013

    vree thread starter macrumors member

    Joined:
    Mar 8, 2013
    #7
    Ok I just saw your post. But I just restored to 5.1.1 with preserving baseband.

    I didn't know that 6.1.3 was jailbroken.

    So didn't you mean use "snowbreeze" to make a new custom firmware?

    Yeah I know alot of question but now that I am on 5.1.1 I want to be able safely upgrade back to 6.1.2 or 6.1.3 while reserving baseband and jailbreaking again.

    EDIT: Am I not better of upgrading to 6.1.2 reserving baseband and then using evasion?

    Or should I just make another custom firmware of 6.1.2 with snowbreeze. And upgrade straight to hacked firmware? Or Will I get another 1600/1601 or 14 error??
     
  8. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #8
    yes, use sn0wbreeze to make the firmware but using ifaith to check if the blobs were valid or not. *dumb moment* forgot sn0wbreeze ifaith mode was updated to support the new validation method

    there is currently no possible way for you to upgrade to 6.1.2 as you don't have the valid shsh blobs for it. you must make a custom firmware for 6.1.3 using sn0wbreeze

    you must use redsn0w to jailbreak ios 6.1.3 (unless sn0wbreeze already does that for you when making the custom firmware)
     
  9. tonfishs macrumors newbie

    Joined:
    Apr 28, 2013
    #9
    yeah,The ony thing I really care about is being on firmware 6.1.2 and using preserving baseband or I can't make calls.[​IMG]
     
  10. vree thread starter macrumors member

    Joined:
    Mar 8, 2013
    #10
    Hi everyone, just posting here to say thanks to everyone who helped me.

    I'm now on Ios 6.1.3 untethered, preserved baseband and jailbreaked.

    And this all thanks to you people =D
     

Share This Page