Please Help! - Sorry First Timer

Discussion in 'MacBook Pro' started by Racivor, Jul 15, 2012.

  1. Racivor, Jul 15, 2012
    Last edited: Jul 15, 2012

    Racivor macrumors newbie

    Joined:
    Jul 15, 2012
    #1
    Hi everyone! So I have a MacBook Pro late 2011. I don't think I really need to disclose any other information. I'm running the latest OS, etc.

    Okay, so whenever I'm playing Team Fortress 2, and I crouch (using the Command key) and then I want to shoot (using click), it causes me to right-click, doing something completely different than what I want. I don't use Command + click as a regularly, so is there a way to disable Command + click giving me a right click function?

    Thank you! Sorry I'm new to the forums and Mac's in general! I love it by the way. :D

    Edit: was this placed in the right section?
     
  2. Racivor, Jul 15, 2012
    Last edited: Jul 15, 2012

    Racivor thread starter macrumors newbie

    Joined:
    Jul 15, 2012
    #2
    Um also is this a good title? Sorry!

    Edit: I am sorry I forgot to edit my first post!
     
  3. TheMacBookPro macrumors 68020

    TheMacBookPro

    Joined:
    May 9, 2008
    #3
    Command-click should not result in a right click.

    Are you referring to Control-clicking?
     
  4. mohsy90 macrumors 65816

    mohsy90

    Joined:
    Feb 4, 2011
    Location:
    New York
    #4
    Yeah......these settings are likely in the game itself not the OS. You need to go to game controls and change it.
     
  5. Racivor thread starter macrumors newbie

    Joined:
    Jul 15, 2012
    #5
    Yes that is what I mean!
     
  6. TheMacBookPro macrumors 68020

    TheMacBookPro

    Joined:
    May 9, 2008
    #6
    These shortcuts have been implemented in the OS at a low level... I don't believe there's a way to disable it.

    You can change the keybinding for crouching in the game to a different key to avoid this issue though.
     
  7. ugp macrumors 65816

    ugp

    Joined:
    Jan 7, 2008
    Location:
    Inverness, Florida
    #7
    I've learned to use "C" to crouch. I have to remap a few keys to get around the way the keyboard feels on a Mac versus when I played back on a PC.
     
  8. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #8
    To edit your thread title to a descriptive one, to get a knowledgable audience and help making the thread easier to find for people looking for the same information, just click on the [​IMG] button on the bottom right of your original post and then click the [​IMG] button below your message.
     
  9. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #9
    You'd be surprised...Anyway, regardless, I know that Diablo 3 has an in-game option for ignoring system KB shortcuts, you could see if TF2 has the same thing, or disable the shortcuts in system preferences before playing.
     

Share This Page