Please help! Track pad of unibody MB does not work!

Discussion in 'MacBook Pro' started by dess, Aug 3, 2011.

  1. dess macrumors newbie

    Joined:
    Aug 3, 2011
    #1
    Hi there! The track pad of my bf's unibody MB stopped working! I have tried restart, removing the battery, resetting the SMC, plugging an external mouse but nothing seems to fix the problem. The keyboard works fine but that's not of much use. :mad:

    Any ideas what might fix this?

    Thanks in advance.
     
  2. TheZTwin macrumors newbie

    Joined:
    Aug 3, 2011
    #2
    If you take the battery out of the bottom, you will see some wires and circuit boards covered with a transparent piece of plastic. You might see some wires out of place or something like that.
     
  3. iamBATMAN macrumors newbie

    Joined:
    Jul 17, 2011
    Location:
    New York
    #3
    Start the Macbook up holding the option key - When you're on the screen that displays your Macintosh HD boot volume see if the trackpad has functionality.
     
  4. dess thread starter macrumors newbie

    Joined:
    Aug 3, 2011
    #4
    TheZTwin: I read a lot about the wires underneath the battery, but the unibody MB does not have any wires sticking out.

    iamBATMAN: I tried this and now the problem is fixed (honestly have no idea why) but I am sure this is only a temporary solution as this has happened before.

    Any ideas why is it happening and what can I do to fix it permanently?
     

Share This Page