Please help: Upgraded to Sierra and now can't connect to internet

Discussion in 'macOS Sierra (10.12)' started by Herdfan, Dec 24, 2016.

  1. Herdfan macrumors 6502

    Joined:
    Apr 11, 2011
    #1
    I bought my daughter a new iPhone 7 for Christmas. She had already backed up her old 5S on her MBP 8,1. When we got home, she plugged in the new 7 and went to restore, but it would not work with version of iTunes she had. So she upgraded to the newest listed and tried again, but no go. She needed an even newer version which meant she needed to upgrade from Mountain Lion. So I took over and upgraded her to Sierra. Everything went smoothly except it will not connect to the internet.

    At first I thought it was a WiFi issue as that is what my first searches revealed, but after trying all their suggestions I still couldn't connect to the internet. So I tried printing to a WiFi printer and that worked, so it was connected to WiFi. I tried pinging from Terminal with both IP and names and both worked. So the computer is connected to the internet, I just can't browse.

    Just for fun I opened the Airport Utility and this is where it got strange. I am connected to WiFi via a Time Capsule. When you click on the WiFi in the taskbar, it will show being connected to Time Capsule. But if I open the Airport Utility all it shows is Internet. I have a Time Capsule and 2 Expresses on my network, but the AU shows none of them. It does on my iMac and it is connected to the internet just fine. Otherwise I would have been able to post this.

    I also tried a wired connection and it didn't allow me to connect.

    Any suggestions short of using my TM backup to go back to ML?

    Thanks and hope everyone has a great Christmas.
     
  2. Zazoh macrumors 6502a

    Zazoh

    Joined:
    Jan 4, 2009
    Location:
    Mico, Texas
    #2
    Sounds like a DNS problem, if you have internet connectivity but no browsing.

    Regardless, delete the Wifi from Network Preferences and try again.

    Click the WiFi symbol | Open Network Preferences | WiFi |
    Click on Advanced
    You will see your WiFi connection options, delete the one for Time Capsule and any others you have in your home. Then When they pop back up, choose the correct one that actually has a connection to the Internet.
     
  3. Herdfan thread starter macrumors 6502

    Joined:
    Apr 11, 2011
    #3
    I thought that first as well. But one of the "fixes" was to use the Google DNS servers at 8.8.8.8 & 8.8.8.4 and that didn't work. Also I can ping Google via the terminal with both 74.125.29.105 & www.google.com. So some DNS is working somewhere.

    But I can't access Google via 74.125.29.105 so that should rule out a DNS issue.

    Thanks for trying. :)

    Edit: Have tried with both Safari and Chrome.
     
  4. aquilc macrumors member

    Joined:
    Dec 26, 2014
    Location:
    Malta
    #4
    Try resetting the modem... Or clearing all WiFi settings + preferences.

    Also try logging in with a guest account.
     
  5. Herdfan thread starter macrumors 6502

    Joined:
    Apr 11, 2011
    #5
    Did all that. Cleared many of the .plist's and restarted, didn't work. Reset Time Capsule & Modem, no help.

    Will try that when I get back home. Thanks.
     
  6. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #6
    Try running the OS Wireless Diagnostics Utility to see if any report results hold a clue -- https://support.apple.com/en-us/HT202663

    Try booting into Safe Mode, then reboot into normal mode -- https://support.apple.com/en-us/HT201262
     

Share This Page