Please help urgent!!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cake90036, Feb 4, 2011.

  1. cake90036, Feb 4, 2011
    Last edited: Feb 4, 2011

    cake90036 macrumors regular

    Joined:
    Jan 7, 2008
    #1
    My iphone won't display an image....
    So here is the story, I was changing the digitizer on the iphone 3g and after everything was said and done, I put it back together, All was working fine, I was putting the case back on and I got a white screen, I took it apart, fixed the cable, closed it back up... White screen again, then it was working. Took it apart again and noticed one of the cables on the lcd were bad, Changed the lcd with a brand new one and now there is no image at all? WHAT IS THE DEAL!!!
    Please help me asap as this is urgent
    ps. the prongs on the connecting motherboard look fine.

    Also I checked the conections again everything is connected.
     
  2. saberahul macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    USA
    #2
    Not to sound stupid but did you connect the right cable to the right location?
     
  3. cake90036 thread starter macrumors regular

    Joined:
    Jan 7, 2008
    #3
    Yea i made sure everything was connected properly and did so about 4 times i honestly have no clue what couldve went wrong
     
  4. cake90036 thread starter macrumors regular

    Joined:
    Jan 7, 2008
  5. saberahul macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    USA
    #5
    Can't think of anything off the top of my head. Maybe open it up and provide some pictures but can't guarantee anything.
     

Share This Page