Please help..USB ports diabled and will not enable.

Discussion in 'MacBook Pro' started by Purgatori, Jan 29, 2014.

  1. Purgatori macrumors newbie

    Joined:
    Jan 29, 2014
    #1
    Hello..I got the message my usb ports were disabled because they were using too much power. At the time only my phone was plugged into my usb..which it is nearly all the time. I researched and found a couple solutions. One being the PRAM reset and another the SMC reset? I've tried both of these solutions several times and neither one has worked...I also tried letting my battery die and leaving it off for a while. I've tried a few different devices with different cables as well..At this point I'm very frustrated. I had considered getting rid of my macbook for a while and this is really pushing me in that direction. It seems like a really silly solution to disable my ports.

    Thank you for help in advance.

    macbook pro 13 late 2011
    Model Name: MacBook Pro
    Model Identifier: MacBookPro8,1
    Processor Name: Intel Core i5
    Processor Speed: 2.4 GHz
    Number of Processors: 1
    Total Number of Cores: 2
    L2 Cache (per Core): 256 KB
    L3 Cache: 3 MB
    Memory: 8 GB
     
  2. durkkin macrumors regular

    Joined:
    Sep 23, 2013
    #2
    Generally that happens when something isn't plugged into the port all of the way. USB spec allows for the ports to provide 1A of electricity at 5V. When something is loose, it can create a short drawing too much current too quickly, resulting in battery drain, but even worse high heat and possibly damage. Macs can detect when the current draw is too high and disable the ports for protection.

    When that happens a simple restart or in some cases an SMC reset is all that it takes to bring the ports back up. Check to see if your bluetooth is working. That resides on the same bus as the USB ports.
     

Share This Page