Please help! Watch will not install apps and drops connection

Discussion in 'Apple Watch' started by dan-K, Dec 19, 2015.

  1. dan-K macrumors regular

    Joined:
    Sep 19, 2012
    #1
    Hi,

    I'm wondering if anyone can help me, I'm at the end of my tether!

    I went to install some apps on my apple watch last night, but for some reason the apps would get stuck on "Installing" on the Watch App on my iPhone and not appear at all on my watch.

    I went ahead and did a hard reset on my Watch and iPhone, but this did not work. I then went ahead and did a full reset of my watch and then paired this back with my iPhone.

    Upon closer inspection it appears that the watch and phone are regularly dropping connection, as for example when I'm trying to install apps on the watch, I see the bluetooth icon on my phone turn to grey and then turn back to connected. I don't think this is a problem with my phone's bluetooth as I don't have any problems with other bluetooth devices.

    Can anyone help? I can't install any apps! Is my watch bluetooth faulty?

    Thanks in advance!

    Dan
     
  2. testcard macrumors 68020

    testcard

    Joined:
    Apr 13, 2009
    Location:
    Middle England
    #2
    Have you tried turning off Bluetooth on your iPhone, and then checking that Watch and iPhone are still connected over wifi - green cloud symbol in Settings glance. Can you then load the apps?
     
  3. dan-K thread starter macrumors regular

    Joined:
    Sep 19, 2012
    #3
    I just tried using just wi-fi. It installed one app properly but the rest when I tried to add them to the watch they would say "installing" for ages and then just toggle back to off...
     

Share This Page