Please HELP with BitTorrent

Discussion in 'Mac Basics and Help' started by zforrester, Sep 18, 2005.

  1. zforrester macrumors member

    Jun 12, 2005
    I love BitTorrent.. especially for legal stuff like Diggnation videos or what have you, but I've recently moved, and now BT isn't working. I've opened up a ton of ports in the sharing prefs, but still no worky. doesn't matter how popular the file is. What is up with that? Also, iTunes is giving me a REAL hard time downloading podcasts... it seems to take days to get one episode, and even then it's spotchy. Some shows i'm trying to get are TWIT, Dawn and Drew, and Diggnation, but I keep getting an error message!
    Please help!
  2. 7254278 macrumors 68020

    Apr 11, 2004
    What is the error message, maybe you have to open some ports on your router.
  3. DarkNetworks macrumors 68000


    Apr 12, 2005
    same here. i've open ports 49152 and configured it in my Azureus client but still not working.i don't seem to be able to download and connect to i switch to 6881 did the same thing...but still downloads are slow like 1.0kB/s and still i can't seem to connect to seeders and of course i'm stuck at 97.8& and some even terrible 99.9%
    Anyone has any sort of solution for this?
  4. zforrester thread starter macrumors member

    Jun 12, 2005
    the error message i get in iTune is as follows:
    There was a problem downloading "PODSHOW TITLE".
    The Netwrok connection timed out.
    Also, some times it says "the network connection has been reset"
    For BitTorrent, I've only opened port 6881 (TCP), should I try some others?
  5. Laplace macrumors member

    Aug 14, 2005
    Huntsville, AL
    How do you open ports on your router or on your computer? I am trying to set up Azureus, but anytime I try a different port, Azureus tells me "NAT error". However, BitTorrent (original client) client works fine, although it seems AWFULLY slow, like 10KiB/s if im lucky and some dont even work, even though there are plenty of peers and seeds.
  6. jonat8 macrumors regular

    Dec 17, 2004
    United Kingdom
    The reason for slow-ish downloads is because you're not uploading and you can't upload unless you open the right ports.

    If you're using a hardware router then you need to go to the router's control panel (usually or similar - check the manual) and open the ports that way.

    If you have a hardware router that supports Universal Plug & Play (uPNP) then if you enable it then Azureus will automatically tell your router to temporarily open the required ports while it is running. Check the router control panel to see if it supports it.

    If you're using the Mac OS X firewall, you can open the port in System Prefs > Sharing > Firewall.

Share This Page