Please help with dead Mac: Dual 1.25 G4

Blue Velvet

Moderator emeritus
Original poster
Jul 4, 2004
21,922
181
Came into the office this morning to find our 4th workstation which runs the ISDN and the scanner not powered up. It's a MDD dual 1.25 with 1.5gb RAM and running OS 10.3.6.

I've changed the power lead and there was a slight spark when I plugged it in but the power switch is not working... it's not even booting up.

Any ideas?

Thanks
BV
 

mad jew

Moderator emeritus
Apr 3, 2004
32,191
5
Adelaide, Australia
That sucks. Is it responding at all to the power button? Does it get to the POST (start up tone) or even half a POST? Does it beep or are there any red flashing lights? :)
 

Mookamoo

macrumors member
Aug 7, 2006
72
0
Might be some dead RAM. Try taking the DIMMs out and putting them back one at a time and seeing if that helps.

Had a similar problem a while back and ended up dumping the machine. I think the logic board was fried. Put HD in different machine and claimed on the insurance saying it had coffee dumped on it.
 

Queso

Suspended
Mar 4, 2006
11,821
7
Says dead power supply to me. You need to get that booked in with a repair shop.
 

Mord

macrumors G4
Aug 24, 2003
10,090
21
UK
My psu's always spark up when being plugged in, they are designed to be able to take that, if your feeling adventurous you can hot wire it to boot by shorting the green wire of the power supply cable with any black ground wire (use some tweesers or something), it's a low current you won't be shocked), if that does not boot it then the psu is dead, if it semi-boots and just the fans/HD's come on then the logic board is probably buggered, if it turns on normally then your power button board may of just failed, which is a fairly rare occurrence.
 

Blue Velvet

Moderator emeritus
Original poster
Jul 4, 2004
21,922
181
dynamicv said:
Says dead power supply to me. You need to get that booked in with a repair shop.

You're probably right, which I've now done... Square Group are picking it up later this week. I haven't got time to faff round with it as I'm up to my neck in work...

Thanks all.
 

asencif

macrumors 6502
Dec 21, 2005
323
0
Does the computer power button light up brieftly then turns off when you press it?

Regardless, have you unplugged the power cable, opened up the Mac and taken out the Logic Board battery, then reset the PMU by pressing the button for about 1 sec and letting go. After that wait about 15 seconds and put the battery back in then about 3-5 mins plug the power cord back in and try to boot it.
 

CanadaRAM

macrumors G5
Right asencif

Failure to power on is sometimes a dead PRAM battery, or corrupted PRAM. Sometimes it starts powering up but doesn't 'make it', sometimes there is no video. Occasionally, pushing the power switch, fail, then pushing the power switch again quickly is enough to start it.

Resetting the PMU (or leaving the battery out for overnight) will clear the PRAM, popping in a new battery is always worth it on any machine over 3 years old. The batteries last 3 - 6 years depending on the Mac model, and the more time the machine is turned off, the shorter they last. For $10 or so if it saves an occasional trip to the shop, it's worth trying. An establishment with more than a couple of Macs would do well to keep a battery or two on hand. They are available at Radio Shack or electronics parts sellers, you want a 1/2AA, 3.6V Lithium batttery with no pigtails.
 

Raid

macrumors 68020
Feb 18, 2003
2,153
4,587
Toronto
asencif said:
Does the computer power button light up brieftly then turns off when you press it?

Regardless, have you unplugged the power cable, opened up the Mac and taken out the Logic Board battery, then reset the PMU by pressing the button for about 1 sec and letting go. After that wait about 15 seconds and put the battery back in then about 3-5 mins plug the power cord back in and try to boot it.
I was going to post the exact same thing. On my Sawtooth* I had a similar problem where the power button light up when pressed but nothing else happened. Pressing the PMU reset fixed it right up. Hopefully you don't have spend anything to get it fixed BV.

*(note to self ask when quad-core chips are coming so I can get a new machine) ;)
 

Eidorian

macrumors Penryn
Mar 23, 2005
29,085
290
Indianapolis
asencif said:
Does the computer power button light up brieftly then turns off when you press it?

Regardless, have you unplugged the power cable, opened up the Mac and taken out the Logic Board battery, then reset the PMU by pressing the button for about 1 sec and letting go. After that wait about 15 seconds and put the battery back in then about 3-5 mins plug the power cord back in and try to boot it.
Yes, I've had the same thing happen to! Make sure you reset the PMU first. I've brought some "dead" Power Macs back to life with just that. :D
 

Blue Velvet

Moderator emeritus
Original poster
Jul 4, 2004
21,922
181
Raid said:
Hopefully you don't have spend anything to get it fixed BV.

It's not my money. :D

It's gone to the shop and no, the button didn't light up. If it was my machine, I would have tried everything along the lines of what you guys were suggesting but it's not mine — it's the office's, and now they can find out what happens after overlooking my request for a maintenance contract.

Gives you a nice warm fuzzy feeling inside... ;)
 

yellow

Moderator emeritus
Oct 21, 2003
16,032
1
Portland, OR
Blue Velvet said:
Gives you a nice warm fuzzy feeling inside... ;)
The kind that makes you want to scream "I ****ING TOLD YOU SO!" at the top of your lungs? That's my 2nd favorite warm fuzzy feeling inside!

The first comes with lactose intolerance.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.