Please help with e-mailing Excel for Mac files

Discussion in 'Mac Apps and Mac App Store' started by koigirl, Jan 23, 2012.

  1. koigirl macrumors 6502a

    koigirl

    Joined:
    Jul 29, 2011
    Location:
    Raleigh, NC
    #1
    Hi,

    I am trying to send Excel for Mac document attachments in an e-mail from my Lion MBP and they are coming up as Text Edit documents which cannot be opened by me or the recipient :confused: They are labeled as Excel documents on my desktop. Does anyone know what I am doing wrong? My Excel version is 2008. Thanks for any help.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    What file extension do they have? Are you sure you're attaching a spreadsheet file and not an alias? To quickly attach, just drag an Excel file and drop it on your Mail icon on your Dock. That will create a new message with the file already attached.
     
  3. koigirl thread starter macrumors 6502a

    koigirl

    Joined:
    Jul 29, 2011
    Location:
    Raleigh, NC
    #3
    They are xlsx files - does that mean they are alias files? Do I need to rename? I always replace files after I update them and drop the extension to replace/save as original.:confused: I'm sorry- I'm a bit clueless about this and only use Excel at home intermittently. Please bear with me. Thanks for the help.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    .xlsx files are fine. They are not alias files.
    What do you mean you drop the extension? Do you edit the file name and remove the .xlsx from them? Does that mean the files you're attaching have no extension? If so, that's your problem. Leave the .xlsx extension on the files. You should never have to remove the extension.
     
  5. koigirl thread starter macrumors 6502a

    koigirl

    Joined:
    Jul 29, 2011
    Location:
    Raleigh, NC
    #5
    If you look at my saved files on my desktop, they are labeled as xlsx files. If I open a file and modify it, I always do it "save as" and drop the extension to the original file name so I don't have duplicate files, only the newest one. I will go back and look at them.

    The strange thing is that when I went back and test-sent them to myself one at a time in an e-mail, they were sent in Excel, not Text Edit, form and I was able to open them. All except one. :confused:
     
  6. milbournosphere macrumors 6502a

    milbournosphere

    Joined:
    Mar 3, 2009
    Location:
    San Diego, CA
    #6
    Are you using Mail to send them? You might try emailing directly from Excel. It could also be that dropping the extension is causing the problem
     
  7. koigirl thread starter macrumors 6502a

    koigirl

    Joined:
    Jul 29, 2011
    Location:
    Raleigh, NC
    #7
    I'm sure you're gritting your teeth about now and I do thank you for trying to help me!:eek:

    ----------

    How do I add a dropped extension back? Just open the file, hit save, and let it do so with automatic extension?
     
  8. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    Or you can click once on the file in Finder to select it, then press Enter to rename the file, then your right arrow (to move to the end of the file name), then type: .xlsx
     
  9. koigirl thread starter macrumors 6502a

    koigirl

    Joined:
    Jul 29, 2011
    Location:
    Raleigh, NC
    #9
    It doesn't make sense because I opened them in Finder again and they are listed as .xlsx files. Will try sending through Excel rather than Mail. Perhaps it's a setting in Mail but I can't see how to adjust setting for attachments in Mail.
     
  10. koigirl thread starter macrumors 6502a

    koigirl

    Joined:
    Jul 29, 2011
    Location:
    Raleigh, NC
    #10
    Thanks for the help. I renamed the files in Finder and then sent directly via Excel and it worked perfectly.:)
     

Share This Page