Please Help

Discussion in 'Mac Basics and Help' started by nickwildman, Feb 15, 2008.

  1. nickwildman macrumors newbie

    Joined:
    Feb 15, 2008
    #1
    I have bought a black mac book just over a year ago and i just moved to china. one morning my comp just wouldnt turn on. it goes to a grey screen with the pin wheel.

    Ive heard others having this problem and ive done everything like reseting pram and such. i dont have my start up cd so i tried using my friends and it says cannot install on my computer. Even when i try the disk utility to seach if all my drives work good its says the same thing.

    I tried to repair the hard drive and it says error on entry or something.

    please please help as i have no one to take mty mac to because im only down in hk once and a while :(

    any suggestions would help..

    is it because its my friends start up disk??

    thanks

    nick
     
  2. tersono macrumors 68000

    tersono

    Joined:
    Jan 18, 2005
    Location:
    UK
    #2
    The install disk will only work if it's from the same model computer - disks supplied with Apple hardware are locked to that particular model.

    It's a longshot, but try starting your computer up into single user mode whilst holding down CMD-S (apple key + S).

    You'll see a bunch of text scrolling up the screen. When it finally stops, type the following at the command prompt:

    fsck -fy

    Hit the enter key.

    It may take a couple minutes to do its thing. If you see a message saying "FILE SYSTEM WAS MODIFIED" or suchlike, run the same command again.

    Now type the following followed by the enter key to restart your computer:

    reboot

    What you've just done is the command-line version of running 'repair disk' in Disk Utility. If the problem is too serious, it may not help, but if it's just minor disk corruption, it might solve the issue for you.

    Good luck!

    PS: be very careful when in single user mode - only type the above commands and be careful that you get them right - it's easy to completely hose your system from this mode unless you're very careful.
     
  3. Quint macrumors member

    Joined:
    Feb 4, 2008
    #3
    If you haven't tried it already, you can try a Shift-boot.
    Power on the Mac while holding down the Shift key.
    Release it when you see the spinning sprocket.

    This will, among other things, force the mac to load only the OS kernal extensions. Since this is what is happening during the spinning sprocket phase of start-up, it may bypass the problem.
    It may take several minutes longer than a normal start-up to start this way, so be patient. I've seen it take as long as ten minutes.

    If your mac boots successfully this way, try to restart normally and see if the problem is gone. Otherwise, restart in Shift-boot (Safe boot) and try removing third-party kernal extensions until you find the one causing the problem.
     
  4. nickwildman thread starter macrumors newbie

    Joined:
    Feb 15, 2008
    #4
    i tried the shift boot and my computer just shuts off. im going to try and do the disk utility like tersono. im going to get my start up cd's mailed to me aswell.
     
  5. nickwildman thread starter macrumors newbie

    Joined:
    Feb 15, 2008
    #5
    ok i just tried the single user disk utility and it says:

    invalid record count (4, 2285)
    volume check failed


    what is a 3rd partuy kernel and how to i take it out?
     

Share This Page