Please, how to jailbrake this iPhone!

Discussion in 'Jailbreaks and iOS Hacks' started by Against Fools, Jan 17, 2012.

  1. Against Fools, Jan 17, 2012
    Last edited: Jan 17, 2012

    Against Fools macrumors newbie

    Joined:
    Jan 17, 2012
    #1
    Hello, i would be glad if someone can have some time and explain this to me. I know it was posted a million times in the forums and everywhere but i need a suggestion and want to be sure i'm doing everything right. This is my first iOS device and this is my first time jailbreaking.
    - I own an iPhone 3gs.
    - the base band is 05.16.02
    - the serial number is **934******
    - It runs right now the 4.3.2
    - It wasn't jailbreak before.
    - It is locked to at&t.
    - My bootrom is new.
    Now this is IMPORTANT please respond to each of this questions as I am afraid to proceed without knowing this answers:

    1. Do I need to upgrade to 5.0.1 through iTunes before jailbreaking or I need a special tool to upgrade?
    2. If I do so will my baseband update? if yes, which one will I have?
    3. Is my bootload
    4. My curent baseband is unlockable and the only option to unlock it after jailbreaking is to instal the iPad BB?
    5. Is there a way to unlock it without installing the iPad BB as I really don't want to lose GPS or any other problems that come with this baseband. Is there any other baseband that is compatible for me?
    6. Will I get the untethered version of 5.0.1 after jailbreak?
    Please advice me also a some good tutorials, right now I follow and read the tutorials from iclarified and I will check what this forum has too.
    Thanks for your time.
    Thank you again for the person responding my questions!
     
  2. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    1. You don't need to upgrade to 5.0.1 to jailbreak. Just open Safari on your phone, type in jailbreakme.com and install Cydia. You are done.
    2. You don't need to upgrade your phone baseband at all to jailbreak.
    3. ?????
    4. Yes, the only way for you to unlock your phone is to install an Ipad baseband.
    5. No. Not all all.
     
  3. Against Fools, Jan 17, 2012
    Last edited: Jan 17, 2012

    Against Fools thread starter macrumors newbie

    Joined:
    Jan 17, 2012
    #4
    Thanks a lot for your quick answer.
    I am sorry for my mistakes i totally forgot what I wanted to say at the third question.
    I didn't know about the option to jailbreak it by installing the Cydia application, what is the catch using this option? Is it the same as jailbreaking it with redsnow?

    Do you know what version of baseband I will have if I update through Itunes?
    I think my best option right now is to save the SHSH blobs and update to 5.0.1 with a custom version that will preserve the old baseband is that correct?
    Maybe in the future the devs will find a solution.
    One more thing, can I use the gevey sim to unlock this iPhone?
    Thanks a ton!
     
  4. heyyitzmelissa macrumors 6502

    Joined:
    Jan 17, 2012
  5. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #6
    There is no catch for using this method. Just a different tool. Comex is the creator/author while redsn0w created by The dev team.

    If you upgrade your phone to 5.0.1, the baseband will be the same at 05.16. So, there is no need for you to create a customs firmware to preserve its baseband. You just need to upgrade it by using Apple official firmware.
     
  6. Against Fools, Jan 17, 2012
    Last edited: Jan 17, 2012

    Against Fools thread starter macrumors newbie

    Joined:
    Jan 17, 2012
    #7
    Ok, thanks but why I keep seeing everywhere on forums that if you upgrade the iOS the baseband might update too and the reason people are not updating when a new version comes out is because they are afraid they might never be able to unlock it again, am I missing something?
    Thank you!

    Here is an example:
    "
    NOTE: The only way that you can update to iOS 5.0.1 while preserving your unlockable baseband is to create a custom IPSW using the latest version of Redsn0w or Sn0wbreeze. "
    or
    " If you have an unlocked iPhone you CANNOT simply upgrade to the iOS 5 firmware. This is because iOS 5 will update your baseband, which means you will not be able to unlock your iPhone after updating iOS 5."

    or it only affects the iPhones that have the "unlockable" basebands?
     
  7. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #8
    Mostly it is applied to phone 4 because if an Iphone 4 with baseband 04.10 or lower can be unlocked with Gevey sim. Here is the listing of IOS and baseband for Iphone 4.

    4.0 to 4.0.1 (Baseband 01.59) - can be unlocked with ultrasn0w & Gevey sim.
    4.1 (Baseband 02.10) - can be unlocked with Gevey sim
    4.2.1 (Baseband 03.10) - can be unlocked with Gevey sim
    4.3 to 4.3.5 (baseband 04.10) - can be unlocked with Gevey sim
    5.0 to 5.0.1 (baseband 04-11) - Can't be unlocked at all

    As you can see above, people who own Iphone 4 want to preserve 04.10 or lower baseband so they can unlock with Gevey sim when they upgrade their phones to latest firmware.

    For 3G/3GS, once you upgrade to stock 4.1 fw or higher, it already upgrade to a baseband that can't be unlocked with ultrasn0w. So, you don't need to preserve your phone baseband now.
     
  8. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #9
    What kind of error did you get when you try it with jailbreakme on 4.3.2?
     
  9. Against Fools thread starter macrumors newbie

    Joined:
    Jan 17, 2012
    #10
    Thank you for clarifying that for me.
    So I guess I'm going to upgrade now through iTunes and see what happens after.
    My last question:
    Can I jailbreak it after updating and somehow activate it without the at&t sim card?
     
  10. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #11
    I never try to use redsn0w 0.9.10b4 to hactivate 5.0.1 3GS. So, I don't know. However, from other post at the dev-team blog, the mod there said it will hactivate your phone to bring it to home screen.

    I have plenty of AT&T sims on hand, so I use the easier method.
     
  11. Against Fools thread starter macrumors newbie

    Joined:
    Jan 17, 2012
    #12
    Update:
    Just updated the phone through iTunes.
    IT DID UPDATE THE BASE BAND.
    the baseband was 05.16.02, now is 05.16.05
    Does that make any difference now? It is still the one that is not unlockable.
     
  12. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #13
    Yeah, still unlockable with that baseband.
     
  13. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #14
    Jailbreakme.com does work on 4.3.2

    @OP now you need to upgrade your BB to 6.15 to be able to unlock.
    Good luck
     
  14. Against Fools thread starter macrumors newbie

    Joined:
    Jan 17, 2012
    #15
    Thank you guys for everything!.
    I jailbroke it with success with redsn0w to 5.0.1 untethered, it was activated automatically.
    Right now i am still thinking if it is a good thing to update the baseband or no...I am still searching forums trying to find another solution :D.
    If I will update the baseband I wont have any chance to downgrade it later, right?

    Thanks again for everything.
     
  15. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World

Share This Page