Please! Need some help with iPhone 3GS! My first iPhone..

Discussion in 'iPhone Tips, Help and Troubleshooting' started by chucksmeg1, Nov 25, 2012.

  1. chucksmeg1 macrumors newbie

    Joined:
    Nov 25, 2012
    #1
    Hello all!
    I am new in this forum and hope someone can help me out here.
    I recently purchased a used iPhone 3gs from a guy here in Berlin, Germany. He was very nice and very honest.
    I got the phone jailbroken with iOS 4.1 installed. I really didn't want to upgrade or anything but because this version of the iOS was too old, i couldn't install ANY apps. They were all incompatible with this old version of iOS.

    So my odyssey began. Forum after forum, video after video, i tried learning as much as i could about upgrading and jailbreaking. I finally downloaded the 6.0.1 firmware and the latest version of redsn0w. First i recovered the phone and upgraded from iTunes to the latest iOS. Then, with redsn0w, i selected the firmware previously downloaded and jailbroke it, selecting only the option "install Cydia" and not the "iPad baseband" one, for fear of bricking or for fear of not being able to ever being able to recover the device. So i spent literally 2 days in the whole process and finally got passed the activation of the device, downloaded the packages in Cydia (ultrasn0w and all) and etc etc etc.

    But my phone now still says "No Service", no matter what. I even have the "original" Sim card the guy gave me, and nothing. Just for a fact, i even tried restoring the device and activating it with the original Sim and original iOS through iTunes, but it still acused no Sim inserted. I am very disappointed and sad after two days of little sleep trying to get my first iPhone to properly work.

    The phone was working before (reception at least) so i know its not a hardware problem.

    Anyone has any thoughts or suggestions on how could i possibly have it recognize my O2 Sim card from Germany?

    My 3gs was made in week 39 of 2009 and was AT&T locked, i suppose.

    Any help is greatly appreciated!

    Thanks!

    Paulo
     
  2. PinoyAko macrumors 6502

    Joined:
    Nov 25, 2012
    #2
    Hi,
    I am also new here and was in the same boat as you. What I did to get out of this problem is I purchased a factory unlocking service from eBay. It really worked for me.

    Hope this will help you.
     
  3. chucksmeg1 thread starter macrumors newbie

    Joined:
    Nov 25, 2012
    #3
    I did the same thing actually! Just today i bought this unlock (about 10 hours ago) and still haven't received any code or nothing..how did the process work for you exactly?

    Thanks!
     
  4. PinoyAko macrumors 6502

    Joined:
    Nov 25, 2012
    #4
    The seller quoted that it will take about 24 hours for the unlock to take effect. As long as you gave your IMEI correctly then you will be fine. :)

    By the way, you need to restore your iPhone after receiving a note from your seller that the unlock has taken . iTunes will let you know that the phone has been unlocked after the restore.
     
  5. chucksmeg1 thread starter macrumors newbie

    Joined:
    Nov 25, 2012
    #5
    Yeah, i saw this up to 24hr thing on the ebay page..i was just wondering because i didn't get any confirmation email after posting my IMEI to them..only on the webpage itself.

    But well, let's just wait and see..

    Thanks for the replies though :) Good to know you went through the same thing and it worked fine for you!

    cheers!
     

Share This Page