PLEASE PLEASE HELP! Big problems with Wireless Connectivity... URGENT!

Discussion in 'iMac' started by McPhee123, Nov 4, 2010.

  1. McPhee123 macrumors newbie

    Joined:
    Nov 4, 2010
    #1
    Hey guys, I'm new here and am in need of help!

    I have got my girlfriend's iMac for 6 months while she is away on a course... I set it up about a month ago and the wireless connected straight away, and there have been no problems at all... until yesterday.

    The iMac says it is connected to the network, full signal, but I cannot access the internet. My iPhone connects fine, as does my mum's iTouch.

    Sometimes it also does not connect to the network... AirPort finds it... but the connection times out!

    I have a desktop PC too, which is connected to the router via an Ethernet cable, and the internet works fine on that too. Could someone shed some light on this?

    Thanks in advance

    Steve
     
  2. McPhee123 thread starter macrumors newbie

    Joined:
    Nov 4, 2010
    #2
    I don't want to have to tell her I broke her Mac :(
     
  3. McPhee123 thread starter macrumors newbie

    Joined:
    Nov 4, 2010
  4. Stinkypalm macrumors member

    Joined:
    Feb 14, 2007
    #4
    Had the same problem, resetting safari worked for me.
     
  5. rugonnagraduate macrumors member

    Joined:
    Jun 10, 2009
    Location:
    Charlotte, NC
    #5
    Does it show your connected to YOUR network? Is it possible trying to connect to another network? What kind of router? Does it support 5ghz. Sometime the older 2.4ghz routers get intereference with 2.4ghz home wireless phones.
     
  6. borcanm macrumors regular

    Joined:
    Nov 4, 2008
    #6
    Ugh, Ive had this and its all Apples fault. This has happened to me with my home router and at university with their wifi. The mac is not broken, its just being an A hole, and will not accept or cannot find your routers IP, so you have to tell your mac to connect to your routers IP manually (a 5 second fix).

    Go to System Preferences> Network> Select the Airport tab> Select the TCP/IP tab> Now see where it says "DHCP" change it to "Using DHCP with manual address"> In the "IPv4 Address" box type in the IP address of your wireless router. This is not the same as your internet IP. This is an IP specifically for your router; for example all D-Link routers have the IP 192.168.0.1 (type that if its a D-Link). This IP should be with your wireless modem's documentation, or do a quick google search ex. "Linksys modem IP" will get you 192.168.1.1
    After doing that my wireless worked on my MBP.

    Keep me posted.
     

Share This Page