Please, please help! MBP not connecting to the internet

Discussion in 'MacBook Pro' started by pokeystackle, Jun 10, 2013.

  1. pokeystackle macrumors newbie

    Joined:
    Jun 10, 2013
    #1
    So, woke up one day to have my MacBook Pro (2.4 ghz intel core 2 duo) not linking to the internet.

    I have an Airport and a router from service provider.

    1. Tried everything from resetting IP addresses, to deleting and creating new link to Airport.
    - Restarting everything.
    - Reinstalling computer system.
    - Deleting files.
    - Zapping pram. Etc.
    Anything I could find tried.

    2. Tried hard wiring the laptop to the router....nothing. No internet connection.

    OH, and my system seems to running a little sluggishly. Snow Leopard. (was up to date, but because of reinstall not so. need internet to upgrade again)

    So...
    1. What is the problem?

    2. Do I need to replace the airport antenna?
    3. Do I need a new internet card? (Does the MacBook Pro even have an internet card?)
    4. I saw there are those little USB antennas that some people have used.

    Thanks for your help in advance.
    I am at my wits end.
     
  2. Steve121178 macrumors 68040

    Steve121178

    Joined:
    Apr 13, 2010
    Location:
    Bedfordshire, UK
  3. Killerburst macrumors newbie

    Joined:
    Jun 27, 2010
    #3
    If you tried an ethernet connection from the laptop direct to the modem and you still have no internet connection, then you can deduce the problem is not related to your internal wireless circuitry, nor your Airport. Call your ISP.
     
  4. pokeystackle thread starter macrumors newbie

    Joined:
    Jun 10, 2013
    #4
    Also

    To add to this...

    All other phones, pads, computers are working of the internet/airport fine.

    And, when in the Network window, it is saying that Airport connect is fine, Ethernet connection is fine. I have also done pinging and that comes back fine.
     
  5. Killerburst macrumors newbie

    Joined:
    Jun 27, 2010
  6. pokeystackle thread starter macrumors newbie

    Joined:
    Jun 10, 2013
    #6
    In airport utility I see my airport on the left side, green dot beside it.

    It shows the name, IP address, version and ID on the right.
     
  7. pokeystackle thread starter macrumors newbie

    Joined:
    Jun 10, 2013
    #7
    Oh. And I am trying to back up my system before wiping it and reinstalling everything (hoping a reinstall fixes) and the backup is very slow. About 1mb per min. I have 100gb to back up. *sigh*
     

Share This Page