iPhone Please tell me I didn't brick my iPhone...

Discussion in 'Jailbreaks and iOS Hacks' started by Hawk4255, Mar 26, 2016.

  1. Hawk4255 macrumors newbie

    Joined:
    Sep 21, 2006
    #1
    Hi there. Neurotic non-jailbreaker here, pretty sure I shot myself in the foot with my old iPhone 3GS and I am turning to you fine people for help. I have Googled high and low and tried many different things, none of which have worked and now I am at my wit's end. Allow me to explain:

    I had lent my old 3GS to a friend years ago (old bootrom). Back then, I used redsn0w to jailbreak and unlock it, installing the iPad 06.15.00 baseband in the process so he could use it on T-Mobile. Now, 4 years later, I finally got the phone back from him. Curious to see what was on my phone back in 2012, I decided to restore it to my backup in iTunes that I had made before we jailbroke it.

    Of course the software was well out of date, so I updated it to the most recent firmware via iTunes, iOS 6.1.6. This was where I went WRONG.

    Upon the phone coming out of the firmware update, iTunes says that there is no SIM card installed in the iPhone and that I can not activate it. I had tried my old SIM and even placed my current 6S SIM in an adapter to no avail. I delved into the realm of Google-troubleshooting, and eventually I determined that since I had the iPad baseband installed, I have corrupted the firmware because I upgraded it via iTunes. Like I said, non-jailbreaker here--had no clue.

    Thus far I have tried every potential fix that I have come across, none of which have worked. I fear the problem is that redsn0w didn't support 6.1.6 and can't communicate baseband downgrade to my device. It typically returns an error of USB communication problem. I feel like I may be stuck in between a rock and a hard place and because the device is so old, my chances of finding someone who can guide me through this is slim. All I want to be able to do is get my old data back on there so I can put the phone away and pull it out one day and reminisce.

    Someone taking the time to troubleshoot this with me would be so greatly appreciated!
     
  2. Bl0ckHe1d macrumors 6502

    Bl0ckHe1d

    Joined:
    Nov 19, 2009
    Location:
    Caledonia
    #2
  3. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #3
    iPad baseband is compatible with the older 3GS models, with the older bootrom

    --- Post Merged, Mar 28, 2016 ---
    Do you have SHSH blobs for the 3GS? If you do, try downgrading using iFaith to make the custom ipsw with the SHSH blobs stitched

    Enter pwned DFU mode and restore the device using the custom ipsw

    Afterwards, use a version of redsn0w that supports that iOS version and downgrade the iPad baseband to 5.13.04
     
  4. cyber16 macrumors 6502

    Joined:
    Jan 12, 2013
    #4
  5. Hawk4255 thread starter macrumors newbie

    Joined:
    Sep 21, 2006
    #5
    Ok, problem solved. For posterity's sake, here is how I fixed it.

    First of all, thank you for the responses. I was also following the information I found here, here, and in the comments here.

    Particularly, this passage in the comments of the third link I found to be the winning strategy:

    You have to use redsn0w (at least 0.9.14b2) to restore to version 4.1. Get 4.1 for iPhone 3GS here.. From the opening screen, go to Extras, then to Even more, then to Restore. Select the 4.1 ipsw file you downloaded, then select Remote in the Blobs section. When it asks to keep the baseband say YES (keep the 06.15.00 baseband). From there you will have to put the phone into DFU mode. Let redsn0w do its thing. The phone will reboot and you may be able to get back into the phone. But don't stop there. Open up redsn0w again this time selecting Jailbreak (you should also know beforehand if you have the old or new bootrom, search Google if you don't know), then put phone into DFU mode again. Then redsn0w will take you to a window with options for the jailbreak. You can install Cydia, but most importantly select restore to earlier iPhone baseband. This will downgrade you to an iPhone 05.13.04 baseband. Once the jailbreak finishes and reboots, open iTunes, plug in your phone, and restore to the latest firmware available (6.1.2 as of Feb. 26). iTunes should download and install the update. Once that has finished, you're almost done. At this point the phone is ready to be activated with the carrier the phone is registered to (usually ATT). You will have to put in the correct carrier SIM card, or have the phone unlocked whether through the carrier or software unlock. Then you should be able to activate and use your phone. I hope this helps.

    I gathered that I had to downgrade my 3GS to 4.1 and then use redsn0w to downgrade from the iPad baseband to an iPhone one. Only then could I re-upgrade via iTunes to the most recent firmware (6.1.6).

    To do so, I used redsn0w to put the phone into pwned-DFU mode, and then used iTunes to restore it to 4.1. I was thrilled that SOMETHING was finally happening. However, since it still had that iPad baseband, it was showing the same "no SIM" error as before. I then determined that I could use the final version of redsn0w to downgrade it during jailbreak.

    However, for whatever reason, redsn0w was getting stuck at the "waiting for reboot" phase. No matter how many tries, no matter if I unplugged and replugged, it would hang there.

    After exhausting the web looking for solutions to this new problem, I eventually deducted that the current iTunes was probably the issue here. Since this was such an old phone, there had to be some sort of issue with my modern hardware and software trying to do this.

    I actually had my original hard drive from my MacBook Pro that I have since retired, itself having been retired earlier for an SSD, laying around in an enclosure. This was last used in 2011. Fits the timeline, I figured--all the hardware and software on it would roughly be in line with when this would have been happening. I booted my MBP from that, brought over the redsn0w app, and tried to jailbreak.

    Worked like a charm.

    Elated, I took my newly-old 3GS and plugged it back into my main machine, upgraded to the most recent firmware via iTunes, and restored my old backup onto it. FINALLY!

    I realized that my apps have long since been updated and those wouldn't restore to my old phone since they were made for later versions of iOS, but I'll take it. Now I can put the thing away with some peace of mind. If anyone knows of ways for iTunes to download old versions of apps (I thought this was a thing?), let me know. Either way, thanks!
     
  6. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #6
    I do believe the App Store will download and install the latest version that will support your current iOS version. It will give you a message when the latest one doesn't support your current iOS version and will ask if you want to download a version that supports your iOS version

    It actually wasn't a thing for you to download older versions of an app via iTunes until recently

    http://www.idownloadblog.com/2015/12/25/how-to-download-older-versions-of-ios-apps/

    Although there is the tweak "AppAdmin" which is MUCH more straightforward and easier to use, I don't think it supports iOS 6. Description says it only supports iOS 8 and iOS 9
     

Share This Page