Please walk me through adding a network printer in Snow Leopard...

Discussion in 'macOS' started by cameronfield, Sep 12, 2009.

  1. cameronfield macrumors member

    Joined:
    Aug 11, 2009
    #1
    I've searched everywhere, but I cant find anything that helps...

    I have 2 printers that I want to be able to use with my 13" MBP running Snow Leopard.

    1 is an actual network printer attached to my network, and the other is attached to a Windows XP machine and is networked. All the PCs in my house can see/print from them, but I cant even come close to getting it to work.

    Not sure if this matters or not, but I can see the shared drives/network drives on all my Windows machines from my mac, so I'm not sure why the printers aren't showing up.

    Please help me!!
     
  2. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #2
    For the network printer:

    System Preferences -> Print & Fax -> + -> IP

    Add IP address in Address field.

    For Windows Printer:

    System Preferences -> Print & Fax -> + -> Windows

    Select windows machine and then select printer.
     
  3. onomatopoeia macrumors 6502

    onomatopoeia

    Joined:
    Dec 9, 2007
    #3
    I just went through this myself. This is certainly one case where the task was 100% easier on Windows. It took several hours of frustration on my Snow Leopard machine while, on the Windows machine, the Canon installation software did it automatically in 10 minutes.
     
  4. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #4
    You should also be aware that if the printer attached to the Windows computer is not specifically designed to be a network printer. Then the odds are pretty high that the Mac driver is designed for direct USB connections only.

    Instead you will have to use third party drivers like Gutenprint or hpijs (for HP printers; be sure to also download and install foomatic and gplgs from the hpijs page)

    As for your network printer did you just try the add printer dialogue. Or did you have the install disc find the printer. I often have had more luck letting the installer search the network, for HP's anyways.
     
  5. cameronfield thread starter macrumors member

    Joined:
    Aug 11, 2009
    #5
    Followed your steps for the one that has it's own IP. Leopard said it added it, the name was the IP address. I tried printing a test page and it said

    "network busy, retrying in 5 seconds..."

    "network busy, retrying in 10 seconds..."

    "network busy, retrying in 15 seconds..."

    What should I do?

    Also, for driver what should I use?

    Edit: I also tried going to the advanced section of the add printers page and choosing internet printing protocol, and then putting in the ip so it looked like this "ipp://192.168.1.2". Then I chose "CanonMX700" for the driver. But when I clicked 'add' the add window swings down for like 2 seconds then goes back up and nothing happens at all. What am I doing wrong?!
     
  6. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #6

    You probably want the protocol set to LPD.

    In address, just the IP address, no prefix.

    As for driver, is your specific printer on the list? If not, try the generic postscript driver.
     
  7. cameronfield thread starter macrumors member

    Joined:
    Aug 11, 2009
    #7
    Ok I did some searching and found the mac driver for my Dell 1700. So the driver is installed now.

    Here's what I just tried:

    1) Add printer
    Protocol: LPD
    Address: 192.168.1.2
    Queue: [blank]
    Name: Dell Laser 1700
    Location: [blank]
    Print Using: Dell Laser Printer 1720
    2) I click add, it pops up asking me if I want to use tray 1 or 1+2 and how much printer memory to use...I leave them both default and click continue.
    3) Everything looks fine, but when I try to print a test page...

    "Network host busy, will try again in x seconds"

    And it just keeps looking and looping :(. I'm so close!

    Also, here's another weird thing: I made sure to join the same workgroup as my PCs (name: FieldHome), but when I do add printer > Windows > it says "workgroup" but nothing ever shows up. Could I be doing something wrong?

    Thanks for the help so far!
     
  8. cameronfield thread starter macrumors member

    Joined:
    Aug 11, 2009
  9. lukusc macrumors newbie

    Joined:
    Nov 16, 2009
    #9
    Thanks for this outline. I have a Canon Pixma Pro 9500. Its not a network printer but attached to a print server (Linux NAS RAID device). The usual driver proved unresponsive but the Gutenprint driver worked a dream.

    Cheers
     

Share This Page