Plex Issue

Discussion in 'Apple TV and Home Theater' started by KoolStar, Sep 3, 2014.

  1. KoolStar macrumors demi-god

    KoolStar

    Joined:
    Oct 16, 2006
    Location:
    Kentucky
    #1
    I wanted to get some feedback from a few people. I decided to finally add a plex server to my current setup. All was well with the install and scanning music and movies. However when it scans the tv directory. Whenever it encounters a tv show that has mixed file types it does not add it to the library. That is i have multiple tv shows in a directory and each season in its own folder with media files below them.

    Ex.

    Doctor Who
    - Season 01
    Doctor.Who.2005.S01E01.avi
    Doctor.Who.2005.S01E02.mkv
    ...
    - Season 02
    ...

    Plex is not scanning any directories that have mixed file extensions even with home media scanner.

    Any thoughts?
     
  2. waw74 macrumors 68030

    Joined:
    May 27, 2008
    #2
    I've never had a problem with this, most of my TV folders have mpg and mp4 files in them

    have you tried separating them out (move the whole Dr Who folder out, and make a new folder that only has 1 or 2 files, but the same kind)

    you should check file permissions also

    if that doesn't work, head over to the plex forums, you'll be more likely to get an answer there
     
  3. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #3
    I have a few folders with mixed media types but not many. I don't have any problems with them though. It looks like, from your example, that your naming hearty is correct & consistent, which is important. Agree w/ previous poster that the Plex forums is probably the best place for help if you can't fix. The devs chime in often.
     
  4. Darby67 macrumors 6502

    Joined:
    Jul 5, 2011
    Location:
    the corner of Fire and Brimstone
    #4
  5. Dannyshing27 macrumors regular

    Dannyshing27

    Joined:
    Jan 29, 2013
    Location:
    United Kingdom
    #5
    I think there is a chance is is the naming which is slightly messed up.

    Have you tried downloading filebot and using that to rename your files for you?
     
  6. KoolStar thread starter macrumors demi-god

    KoolStar

    Joined:
    Oct 16, 2006
    Location:
    Kentucky
    #6
    I tried renaming the files and it just seems to skip any folders and or shows that have mixed file types. If the first season has mixed types it skips the entire show. It also does not show the most recent season of many shows. IDK may have to move on from plex. Ive spent more time than I care at this point.
     
  7. Idgit macrumors 6502

    Idgit

    Joined:
    Mar 14, 2004
    #7
    As others have said, rename the main folder to "Doctor Who (2005)" and also rename the individual episodes so they look like this: Doctor Who (2005) - s08e01 - Deep Breath.

    Then, move the entire Doctor Who folder out of your TV media folder. Force Plex Media Server to rescan the folder and update the library. Quit PMS. Put the Doctor Who folder back into the TV folder. Launch PMS and wait for it to scan the library. When it's finished, check to see if all the episodes of Doctor Who appear.
     
  8. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #8
    As above its nothing to do with file types it's all to do with how the root folder is named and then the episodes. Look at the above link and rename the files correctly.
     
  9. Darby67 macrumors 6502

    Joined:
    Jul 5, 2011
    Location:
    the corner of Fire and Brimstone
    #9
    The TVDB is useful to understand exactly how naming should be done for TV Shows since it is the database that Plex uses to name if metadata isn't embedded. The Movie Database (http://www.themoviedb.org) is default for movies.

    I renamed a few files and stuck them in a root folder named, "Doctor Who (2005)", as per my suggestion above. Note different file types and intact they aren't even Dr Who files. Everything worked out with my naming scheme (SxEE) and also the more sophisticated system that you use for files. See screen shots below. Bottom line there is no problem with Plex, naming is everything and if proper naming isn't followed crap output will ensue.

    All you need to change is the name of the root folder, i.e. the Show Name and you will be fine. You might find better results if you follow what Idgit recommended and move it out of the folder, refresh and then move back and refresh.

    [​IMG]

    [​IMG]

    [​IMG]
     
  10. KoolStar thread starter macrumors demi-god

    KoolStar

    Joined:
    Oct 16, 2006
    Location:
    Kentucky
    #10
    This is my example dr who directory. I tried removing it from the directory and rescanning then re-adding them and then scanning again. It added all but the current season. I converted the avi to and MKV and it scanned right away. So all the Dr. Who is all mkv and it works now, but any other show that has mixed file types fails to scan that season of the show. If the season contains all the same file types it shows up. So some shows have for example season 1,2,5 and missing 3, 4 because of mixed filetypes.
     

    Attached Files:

  11. Idgit macrumors 6502

    Idgit

    Joined:
    Mar 14, 2004
    #11
    Post your problem over in the appropriate Plex forum. With luck, a dev will take notice and help you investigate the issue.
     
  12. KoolStar thread starter macrumors demi-god

    KoolStar

    Joined:
    Oct 16, 2006
    Location:
    Kentucky
    #12
    I wanted to thank all for your responses it seems to have been related to permissions that were on the media directory. Again thanks for all the help.
     
  13. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #13
    To remedy, what did you need to change the permissions to? I come across this quite often...
     
  14. wwohl macrumors regular

    Joined:
    May 2, 2013
    #14
    Post in the plex forum

    also, in settings, you can decide which website database will be used to identify files. Try changing that

    Bill
     

Share This Page