Plugging in external hard drive crashes Finder

Discussion in 'Mac Basics and Help' started by spiffyfitz, Feb 14, 2008.

  1. spiffyfitz macrumors newbie

    Joined:
    Aug 16, 2006
    #1
    This is definitely bizarre.

    I updated my Mac OS X to 10.5.2, suddenly, Finder started crashing... wouldn't even load. It would just show the little blue "light" flashing on and off, as if Finder were launching, crashing, launching, crashing.

    After some deduction, I found the problem to be my USB WD hard drive. It used to previously work fine. It has only one partition on it, which is HFS+ formatted. Disk utility verify/repair reports that the drive is fine.

    I really need to access that hard drive now, and the Apple Discussions forums have been unhelpful... can someone help me out?

    Thanks:D
     
  2. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #2
    I only have one WD USB external (a WD Passport drive, the other MyBook is Firewire 400) but I haven't had any problems with it in 10.5.2. Bizarre.
     
  3. spiffyfitz thread starter macrumors newbie

    Joined:
    Aug 16, 2006
    #3
    Bumping with new info!

    Console reports this message:


    2/14/08 8:02:24 PM com.apple.launchd[128] ([0x0-0xc00c].com.apple.finder[145]) Exited abnormally: Bus error
    2/14/08 8:02:33 PM com.apple.launchd[128] ([0x0-0x2f02f].com.apple.finder[387]) Exited abnormally: Bus error

    Thanks for help!
     
  4. oxymoron2007 macrumors member

    Joined:
    Jun 9, 2007
    #4
    I have had the same problem with my WD external.
     
  5. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #5
    Do the following:

    1. Make sure your USB cable is good and you are not plugging into a keyboard port. If you are using a USB hub, disconnect it and plug the drive straight into the computer.

    2. Try another USB port on the computer.

    3. Reset the PRAM without the disk attached.

    4. Perform a "Safe Boot" to clean out the hardware cache.
     
  6. mattmook macrumors member

    Joined:
    Oct 31, 2004
    Location:
    St Albans, UK
    #6
    What worked for me was that my drive was working fine - Disk Utility reported no problems. As such you could navigate to it in the Terminal.

    I found that by deleting the .DS_Store from the root of the drive the Finder magically started to work again. Hope this helps someone.
     
  7. Chris-Crossland macrumors newbie

    Joined:
    Jan 19, 2009
    #7
    Fixed

    Thanks for that. Deleting .DS_Store worked. I have looked all over for a fix for this.

    A bit more about my issue in case it helps anyone.

    I was copying files between 2 x external hard disks connected to my macbook. One was connected by firewire the other by USB. I tried to click on one of the drives and finder closed. I could still use other programs to copy between the disks so the disk checked out ok. Then it started happening on another disk. I then knew it had to be a file system problem but Disk Utility didn't show up anything.

    I deleted .DS_Store from both the external hard disks and i can now access them.

    What is all that about then?
     
  8. mivox macrumors newbie

    Joined:
    Jan 29, 2009
    #8
    OK tried all that ... *argh*

    OK, I have a Mac Mini and a new MBP, both running 10.5.6 ... if I plug my external HD (which has two partitions) into the MBP, all is right with the world. If I plug it into the Mini, the Mini crashes before the partitions mount on the desktop. Not just a finder freeze, but the chilling multi-lingual Restart message overlay.

    I'm assuming there's nothing wrong with the drive or USB cable, since the laptop mounts both partitions just fine?

    1. I've tried plugging it into ALL the USB ports on the mini.

    2. I've zapped the PRAM on the Mini.

    3. I've booted in safe mode.

    4. I even deleted the .DS_store files on both partitions of the external, although I don't think there's anything wrong with the drive.

    In short, I tried everything suggested in this thread, and still I get the Restart Overlay of Doom.

    Any new ideas?

    ADDED: OK, even my card reader is crashing the Mini. Clearly there's something catastrophically wrong with the USB interface ... :(
     
  9. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #9
    First I have a few questions:

    1. Is the mac mini a PPC or intel?

    2. Since you are plugging into a USB port, is the drive being powered by an external power supply or are you trying to drive it with bus power only?
    (You may be exceeding the rated specs for the USB ports on the mini.)

    3. Have you tried an SMC (intel) or PMU (ppc) reset on the mini?

    I have an intel mini core2duo processor. I drive 10TBs of Storage using the firewire port as well as a few USB devices. I have no problems with it and I do a lot of video processing on it (cpu intensive).
     

Share This Page