Plugging in USB device causes OS X to hang

Discussion in 'macOS' started by guitargoddsjm, Jun 28, 2011.

  1. guitargoddsjm, Jun 28, 2011
    Last edited: Jul 11, 2011

    guitargoddsjm macrumors 6502

    Joined:
    Feb 25, 2008
    Location:
    MA
    #1
    Hey, having a bit of a problem here. For the second time in a row, when I plugged my Apple Cinema Display's USB cable into my Macbook Pro (2010 15" i7, if it matters), the system hung. Now let me clarify - the whole system didn't hang, but the right side of the menu bar did. By right side, I mean everything to the right (and including) the left most APPLE menu icon. So that's basically Time Machine, Bluetooth, Wifi, Volume, Time/date, my username, and the Spotlight icon. The 3rd party menu icons are fine (caffeine, dropbox, etc). Also, the hard drive attached to my ACD doesn't mount. The same exact thing happened earlier today. I had my computer charging overnight, and as soon as I plugged the USB cable in, the menu bar froze.

    I tried to delete the SystemUIServer .plist file earlier, I updated to 10.6.8, and I reset the PRAM. Unfortunately, none of that worked because it happened again just now. I then tried killing SystemUIServer; the apple menu bar icons, the 3rd party icons shifted to the right to take their place, and the Apple icons won't come back.

    I have three devices plugged into my Apple Cinema Display: the external hard drive I use for Time Machine, the receiver for my wireless mouse, and my Wacom tablet.


    Now that I'm thinking about it, I may have unplugged the hard drive without ejecting recently (i.e., it might have been right before this started to happen).

    If I restart with the cable plugged in, everything works properly and the drive mounts correctly.

    Any ideas or input?

    If at all possible, I'd like to avoid reformatting the external hard drive or doing anything that would cause my Time Machine backups to be wiped out.
     
  2. guitargoddsjm thread starter macrumors 6502

    Joined:
    Feb 25, 2008
    Location:
    MA
    #2
    It seems like this problem is manifesting itself in different ways.

    I plugged the ACD USB cable into my far USB port (closest to the rear/power jack) not too long ago, and nothing happened. No hard drives mounted, my wacom tablet didn't work, and my wireless mouse didn't work. I launched Disk Utility and saw that the computer recognized that the hard drive (with its two partitions) was plugged in, but neither of the partitions mounted.

    I then removed it and plugged it into the close port. Everything mounted and worked properly.

    I ejected the drives and retried the rear port. The same thing happened, and nothing mounted.

    I then tried to quit everything and restart my computer. The computer didn't do anything. I noticed that Google Chrome was still active in the dock, but there were no Chrome windows (even though there were 3-4 before I hit Cmd-Q, and none after). I could only give my computer a hard reboot with the power button.


    Last night, I repaired my computer's permissions with Disk Utility, and tried running Repair Disk on both partitions of the USB hard drive. Unfortunately, it doesn't seem like any of this helped...

    Hope I'm not rambling too much ;):p
     
  3. spidey3, Jul 12, 2011
    Last edited: Jul 12, 2011

    spidey3 macrumors regular

    Joined:
    Jul 1, 2010
    #3
    Suggestion:

    Try removing all USB devices from the picture and do a full shutdown and boot of the MBP. Make sure that it comes up OK.

    Next try plugging just the disk drive directly into the MBP port, bypassing the ACD. See if the drive is recognized. Try the same on the other MBP port. If the drive is recognized, then use Disk Utility to verify the drive.

    Once you have verified that the drive is OK, then proceed on to the other devices, testing each one individually, directly on the MBP with no hub involved. Only go back to using the hub in the ACD once you have verified that each of the devices work fine on their own without using the hub in the ACD.

    My guess is that your problem is either that one of your USB devices is spewing garbage onto the USB bus [possibly the tablet; I've seen that before].

    Spidey!!!
     

Share This Page