Plz help imac wont dl sc2 :(.. help would be appreciated :)

Discussion in 'Mac and PC Games' started by Tannere, Jul 27, 2010.

  1. Tannere macrumors newbie

    Joined:
    Jul 27, 2010
    #1
    So i go to download sc2 and i don't have the requirements. Ill list what i have and am curious if i could easily update or make a quick fix to be able to play any help would be much appreciated thanks

    Version 10.4.11
    iMac
    Model Identifier: iMac5,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.16 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache (per processor): 4 MB
    Memory: 2 GB
    Bus Speed: 667 MHz
    ATI Radeon X1600:
    iMac:
    Display Type: LCD
    Resolution: 1680 x 1050
    Depth: 32-bit Color
     
  2. philbeeney macrumors 6502

    philbeeney

    Joined:
    Jul 24, 2004
    Location:
    Brampton, ON
    #2
    Below are the minimum and recommended Mac Requirements for StarCraft 2. Seems to me that you meet the minimum requirements on the hardware side but you'll need to upgrade your software from Tiger to either Leopard or Snow Leopard.

    Mac Minimum System Requirements:
    Mac® OS X 10.5.8, 10.6.2 or newer
    Intel® Processor
    NVIDIA® GeForce® 8600M GT or ATI Radeon® X1600 or better
    12 GB available HD space
    2 GB Ram
    DVD-ROM drive
    Broadband Internet connection
    1024X720 minimum display resolution

    Mac Recommended Specifications:
    Intel® Core 2 Duo processor
    4 GB system RAM
    NVIDIA® GeForce® 9600M GT or ATI Radeon® HD 4670 or better
     

Share This Page