PM G5 Dual 2.5 #3

Discussion in 'PowerPC Macs' started by mark8, Apr 2, 2017.

  1. mark8 macrumors member

    mark8

    Joined:
    Nov 29, 2010
    Location:
    WNY
    #1
    ok here's whats going on with the 3rd PM G5 dual 2.5
    As soon as I plug in the power cord the psu spins as well as the hard drive.
    I'm guessing the psu has issues.maybe the logic board
    Any1 run into this scenario?
    thx
     
  2. KawaiiAurora macrumors 6502

    KawaiiAurora

    Joined:
    Dec 16, 2016
    Location:
    Europa
    #2
    If the PSU spins and the HDD is on, I'd bet it's the logic board.
     
  3. QSDP-User macrumors regular

    QSDP-User

    Joined:
    Jan 13, 2015
    Location:
    California, USA
    #3
    Regarding a questionable PSU,
    check out this YouTube that shows a PMG5's PSU being tested while still in place inside the case.
    The fans/etc have been removed exposing the RAM & the PSU's main cable is unplugged.
    If doing this test, carefully note the exact pinholes being used in this test.
     
  4. mark8 thread starter macrumors member

    mark8

    Joined:
    Nov 29, 2010
    Location:
    WNY
  5. mark8 thread starter macrumors member

    mark8

    Joined:
    Nov 29, 2010
    Location:
    WNY
    #5
    Well I got #3 G5 to boot and finally stay on for a while(it gets real hot if I run anything & shuts down). I tried to run a thermal cal but got an error like on #2 G5. intake fan speed error. Like on #2 if you open the door the LEDs come on and the fans ramp up higher(the sensor must be working).
     
  6. benwild_33 macrumors member

    Joined:
    Oct 15, 2016
    #6
    Could be a bad pump, might be worth looking for some aircooling parts for it.
     

Share This Page