Poor Battery Life related to Data

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mgartner0622, Nov 5, 2010.

  1. mgartner0622 macrumors 65816

    mgartner0622

    Joined:
    Jun 6, 2010
    Location:
    Colorado, USA
    #1
    Hello All,

    I currently have an Jailbroken and Unlocked iPhone 3GS. About 4 days ago the battery started having issues.

    On a normal day, at most I can get less than 2 hours out of the battery. I have no applications installed, and the only thing I have configured is MobileMe. (This is without using the phone, in standby the whole time.)

    HOWEVER, If I turn the Cellular Data Network off, I can get through a whole day with the battery still at 100 or 99%.

    What could the issue possibly be? Related to Jailbreak? or do I need a new battery? Also, If i put the phone on Airplane Mode with WiFi on, the same issue happens.

    Thank you for your help.
     
  2. TheodoreRyszIII macrumors newbie

    Joined:
    Nov 5, 2010
    Location:
    Reading, Pa
    #2
    Wirelessly posted (iPhone 4: Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    Well it seems to me, and you said it yourself that if you turn off the cullular data option, your battery lasts. However, the second you turn it back on, it seems that since you have jailbroken your iPhone, it is constantly sending data somehow.

    It sounds very strange, but it appears that data constantly being sent out from the phone.
     
  3. jobless macrumors newbie

    Joined:
    Nov 5, 2010
    #3
    I don't have Iphone 3GS, but Iphone4. My battery drainage is similar to your story. Every time I preform a task (text,youtube, surf, email, etc etc) it will drop 1%. I thought it was dead battery so :apple: sent me a new replacement, which I got today and testing it out

    Jailbreak have nothing to do with battery drainage since I jailbroken my Iphone4 months ago and battery is fine, before this happen.

    Finally, either At&t Data network is *beep* our battery. My problem started after Oct.
     
  4. mgartner0622 thread starter macrumors 65816

    mgartner0622

    Joined:
    Jun 6, 2010
    Location:
    Colorado, USA
    #4
    Yes, I believe you're right.
    I just went to Settings>General>Usage
    Apparently, (All ive done in the past 2 days since i've restored it is sent 2 pictures via email) I've sent over 500MB of Data, and Recieved over 2GB!!!!
    What could this be? Again, the only thing I have is MobileMe and the jailbreak...
     
  5. jobless macrumors newbie

    Joined:
    Nov 5, 2010
    #5
    Did you call At&t about this matter? I'm still testing out the new device out before I call. I'm not sure if Apple will solve this problem by giving me another third Iphone4:D.

    I have more programs install in Cydia, so Jailbreak don't drain (some might improve it). ..I even check other forum to confirm on this matter.
     

Share This Page