Poor network speed

Discussion in 'iMac' started by snafu-2112, Nov 7, 2009.

  1. snafu-2112 macrumors newbie

    Joined:
    Nov 6, 2009
    #1
    I am a new Mac user. I bought a 27" iMac today to replace a dead PC. My download speeds are AWFUL on the Mac. While using the PC, my maximum download speed on a 6 mbit connection was over 850kb/sec. Now, with the mac, I can barely manage 250K/sec downloads. What gives? I am using all the same equipment and cables as before (not using the wireless, and I have it disabled), and if I plug in another PC into my router, it will get the 850+kb/sec download speeds, no problem at all. Is there a setting somewhere that I can change to get things working properly? Poor speeds occur no matter what program I am downloading from, whether it be Safari, FTP, or whatever.

    Any help is greatly appreciated.

    -Kirk

    edit: I just installed parallels, with windows, and I can download at my old speeds. How do I do it in native Mac mode then?
     
  2. thegrillboy macrumors newbie

    Joined:
    Nov 7, 2009
    #2
    I as well am a new mac user and exeriencing same. I have a pc and a mac side by side. i am using uverse (fiber) 18mb down. On my pc it runs super fast, but on the mac i get very insconstant readings. 1.5 to 14 mb. with airport turned off. when airport is turned on, it seems like it wants to control the whole interned everything is slow even the pc. So what are we to do?
     
  3. avihappy macrumors 6502

    avihappy

    Joined:
    Nov 15, 2006
    #3
    This is a tricky problem. My iMac gets my full 20mbps speed. Maybe you should try using another router? Perhaps the router has a problem with OS X?

    Also, you can try this (don't know if it'll help): http://support.apple.com/downloads/Broadband_Tuner_1_0
    To see if the tool above can help you, use this test: http://www.dslreports.com/tweaks
     
  4. tunerX Suspended

    tunerX

    Joined:
    Nov 5, 2009
    #4
    It shouldn't be the router. routers are pretty much oblivious to the OS. But they are not oblivious to misconfigured ethernet, IP, or TCP settings in the OS.

    From my initial thought about your problem. I figured "fragmentation". Then I guessed you must be using DSL or some type of connection that uses PPPoE. Maybe your OS was configured with MTU discovery turned off. Maybe the initial configuration set the MTU to 1500 and adjusting to 1484 could work....

    You can try the broadband tuner, it does make some changes that could help you.

    If you run the Network Setup Assistant - You get the option for choosing airport, dsl, cable modem, and lan. I don't know if selecting the DSL option automatically configures your sysctl settings for a lower MTU.

    If you know how to use your terminal window you can type
    "sysctl -A | grep tcp"
    "sysctl -A | grep maxsockbuf"

    Then paste the output for us to review. Something might be set wrong.
     

Share This Page