Poor performance, or something else?

Discussion in 'MacBook' started by davidjearly, Sep 17, 2015.

  1. davidjearly macrumors 68020

    davidjearly

    Joined:
    Sep 21, 2006
    Location:
    Glasgow, Scotland
    #1
    So, after owning this for a couple of months now (rMB, 1.3Ghz), I've encountered a rather displeasing performance problem. I raved about the capacity of this to do real photo work, with my first edits going great and performance seemingly jiffy enough to handle my needs.

    However, I've recently came across very poor performance whilst doing some flowchart work in Pages. I'm running El Capitan (GM), and latest version of Pages. Moving shapes around is hideous. Everything is lagging like crazy. Is this normal? Is it Pages? Is it the power of the rMB?

    Feedback appreciated!
     
  2. Theozz macrumors member

    Theozz

    Joined:
    Jun 4, 2015
    #2
    El Cap GM (still a beta) might be the culprit ;)
     
  3. davidjearly thread starter macrumors 68020

    davidjearly

    Joined:
    Sep 21, 2006
    Location:
    Glasgow, Scotland
    #3
    Well, it's likely to be the version released, so unless other bugs crop up it's technically not a beta.

    In any case, tried the same file (and a new one) on my wife's rMB (OS X 10.10.5) and it's just the same.
     
  4. Hook85 macrumors member

    Hook85

    Joined:
    Jul 15, 2015
    Location:
    Sheffield, UK
    #4
    I have to say that I'm running the GM and have no issues.

    I've got Windows 10 running (with IE and excel open) as a VM at the moment, Safari, Photos, iTunes, Skim, Messages, Excel and Airmail 2, and it's as quick as it always is with no lag.
     
  5. davidjearly thread starter macrumors 68020

    davidjearly

    Joined:
    Sep 21, 2006
    Location:
    Glasgow, Scotland
    #5
    That's doesn't surprise me. Generally, I get no lag either. It's this specific issue with Pages.
     
  6. maclab macrumors member

    maclab

    Joined:
    Aug 31, 2009
    #6
    Anyone tried running Microsoft Word ? I assume that would be even more of a dog then.
     
  7. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #7
    It may be a specific problem with Pages. I assume you are working with an imported spreadsheet from Numbers? I do recall the '09 version having similar issues with large spreadsheets, as Numbers in general was extremely slow back then.
     
  8. Significant1 macrumors 6502

    Joined:
    Dec 20, 2014
    #8
    If your signature is not outdated, try it on your 15" i7 rMBP (late 2013) and see have it behave.
     
  9. davidjearly thread starter macrumors 68020

    davidjearly

    Joined:
    Sep 21, 2006
    Location:
    Glasgow, Scotland
    #9
    No, it's a flowchart created from fresh in Pages, largely using the standard Shapes.
     
  10. joscejrod macrumors 6502

    joscejrod

    Joined:
    May 16, 2015
    #10
    OS x el capitan gm runs fine, but some apple apps, like pages, have yet to be updated to support el capitan.
     
  11. TyWahn macrumors 6502

    TyWahn

    Joined:
    Oct 25, 2003
    #11
    Why don't you just give it a good ole' fashion restart before starting any projects? When I am having performance issues, a restart fixes it 97% of the time.
    PS running GM if that helps. But I've used this trick as long as I can remember.
     

Share This Page