poor streaming performance

Discussion in 'Apple TV and Home Theater' started by davidwarren, Feb 7, 2008.

  1. davidwarren macrumors 6502a

    Joined:
    Aug 28, 2007
    #1
    Just bought an atv last night and am just now getting to play around with it. I have all my movies stored on a usb external hard drive attached to my iMac, and they are all in my itunes movie directory. I have an all n network (imac, aebs, macbook, atv) and whenever I go to play a movie, it stops every thirty seconds (or sooner) and the blue bar comes up at the bottom and has to re-buffer.

    Needless to say, this is not acceptable performance.

    all my movies are encoded in handbrake, either as .264 or mpeg4, and they are between 1-2.5GB, averaging around 1.6GB.

    I have already unplugged the atv and gave it a few minutes, as I searched and this worked for some.

    Previously to the atv, I had my macbook hooked up to my tv using either frontrow or just quicktime to stream the videos, and that never gave me a problem, so I have to think it is the atv.

    Any ideas? This is really frustrating....


    oh yeah, I have the 40GB atv, and at first I thought it was a problem because the atv was syncing with my music,photos, and I believe 5 movies, however, I have removed all of those, turned off syncing, restarted the atv, and the appropriate combination of the above, and it still is not streaming.

    oh yeah part 2, trailers and youtube videos stream perfectly, so is there something wrong with my video files? what would I check-what should they be?
     
  2. RumMunkey macrumors 6502a

    RumMunkey

    Joined:
    Nov 3, 2006
    Location:
    Canada
    #2
    I'd rule out your tv, since it's brand new.

    Your movies (encode settings) sound about right -even a bit small. My movies come out at probably an average of 3GBs each (I use the default tv settings in Handbrake and add the deinterlace feature when required).

    Your network sounds better than mine (I'm currently streaming tv over only an Airport Express without problems), so you're probably good there.

    External drives shouldn't be a problem, as long as you're connected on a USB 2 port (and it's a USB 2 supported drive obviously). Older USB 1.1 probably won't cut it (I use Firewire 800 personally, which is probably overkill, I've used USB 2 drives before without a problem).

    About that drive... have you used it before for other intensive stuff? Was it responsive? What the speed (rpm) and seek time? If it's a cheapie drive in an enclosure this could be your bottleneck.

    What kind of iMac are you running this through? Got enough RAM? Is the machine doing anything else while you're streaming?
     
  3. davidwarren thread starter macrumors 6502a

    Joined:
    Aug 28, 2007
    #3
    I did a couple things last night, and it works perfectly now, but I am not sure what specifically worked. One thing I did, which I imagine fixed it, was to delete the aliases of my movies in my user account Movies folder, and move the iTunes movies folder to my external hard drive and put the movies into that folder.
    Previously, I had just put the movies into iTunes, without copying the actual file into the iTunes library-not sure what that move is called, but I think you understand.
    Also, I had my iMac mounted on my macbook, not sure if that would have caused any slowdown or not.
    Did a few other things, but like I said, not sure what exactly fixed it.

    BTW, I have a Al iMac, 2.4 GHz, 4 GB ram, and my external hard drive is a Seagate Free Agent 250GB unit, it is only a few months old, so it should be plenty fast. Like I said, it works now, just not sure what fixed it...
     
  4. RumMunkey macrumors 6502a

    RumMunkey

    Joined:
    Nov 3, 2006
    Location:
    Canada
    #4
    Ok good.

    A better solution than making aliases is to store your movies on your external, then optn+drag them into iTunes.

    This temporarily overrides your "copy files to iTunes library" setting and keeps your movie on your external, but makes note of its location.
     

Share This Page