Poor Wi-Fi Performance

Discussion in 'MacBook Pro' started by Rob.G, Sep 28, 2011.

  1. Rob.G macrumors 6502

    Rob.G

    Joined:
    Jan 17, 2010
    Location:
    NW Oregon
    #1
    I couldn't find a more specific Topic area to post this; I hope this will do.

    So, I have two Macs... a MacBook Pro and a MacBook Air, both current-gen models. I have a shiny new D-Link DIR-615 wireless router, which is B/G/N. The router sits maybe 3' from both computers, which sit side by side on my desk.

    Wi-Fi performance is pathetic to say the least. I tried to copy a couple of Thunderbird folders from the MBP to the MBA and it took forever. The first one, in my user's home dir (/Users/rob/Thunderbird) is 6.7 gig. I started it before going to bed last night. It took several HOURS to copy. I was seeing maybe 500kb/s. The other one, 1.2 gb in size, took 20 minutes this morning, same transfer rate. It'd occasionally jump up to 1mb/s, but more often than not, it was in the 500kb/s range.

    It happens going both directions... copying to the MBA or copying to the MBP. These are both decently fast machines and nothing else is using the network... no file downloads from the Internet or anything.

    What can I do to speed things up? Could it be a router setting? I tried searching the D-Link site and their "knowledgebase" is a joke.

    I've had this same problem in the past with Windows machines and different routers. I just figured it was because Windows sucked. But it wasn't until the last week or so that I've tried to do it between two Macs.

    Any ideas?

    Rob
     
  2. Coolestdude macrumors member

    Joined:
    Mar 22, 2011
    #2
    Go into the router setup and make it N only. Turn off B and G. Also, make sure you don't have any 2.4 cordless phones around, and you are not near any operating microwave ovens.
     
  3. gorskiegangsta macrumors 65816

    gorskiegangsta

    Joined:
    Mar 13, 2011
    Location:
    Brooklyn, NY
    #3
    It must be a D-Link routers issue. I've seen a number of complaints concerning this issue from people who use D-Link. I don't believe it is due to a defect, but rather a default setting of some sort. I have a Linksys E3000 router and that thing is blazing fast with file transfers, even though I have a cordless 2.4GHz phone sitting right next to it.

    Check whether the router has wireless N, as well as G and B enabled at the same time. Check for firmware updates to your router.

    I'm not sure where in D-Link router settings it is but it should look like this: (Just type in http://192.168.1.1 into your browser address bar and that should take you to your router settings menu.)
     

    Attached Files:

  4. phyrexia macrumors 6502a

    Joined:
    Sep 3, 2010
    #4
    You may want to consider using DDWRT instead of the stock D-Link firmware. There are other open source options for router firmware (OpenWRT comes to mind). I installed DD-WRT on a 615 just a couple months ago.

    You also may want to consider using FTP instead of...however you were transferring them (i'm betting afp).
     
  5. Rob.G thread starter macrumors 6502

    Rob.G

    Joined:
    Jan 17, 2010
    Location:
    NW Oregon
    #5
    The router isn't the problem. After a lot of playing with it, I finally took it out of the equation. I created an Ad-Hoc network and connected the two computers that way, then tried the copy. Same result. PATHETIC speeds... 30k/sec or so.

    It's definitely within the computers somehow. I don't get it.

    FTP does work very well... rather SFTP (Lion did away with regular FTP). I'm sending the files over that way now, getting many mb/s as it should be. But something's up with regular network sharing.

    Rob
     

Share This Page