Poor wifi performance on Mac mini

Discussion in 'Mac mini' started by MacMiniBoy, May 9, 2012.

  1. MacMiniBoy macrumors newbie

    Apr 28, 2009
    Hi all,

    Hoping I can get a bit of advice here. I'm having terrible wifi issues with my early 2009 Mac mini.

    I have a 20mb ADSL connection at home with a rebranded D-Link router that has N wifi.

    I got a speed test app for my iPhone which estimates my broadband connection is just under 20mb as expected. I've done speed tests on two Windows laptops and get similar results.

    However, on my Mac mini, I can barely get it to pull a speed test of over 1mb. Download speeds are poor and even something as simple as streaming some YouTube videos can be problematic.

    As I say, I have def narrowed down the issue to the Mac mini. Can anyone advise what might be the issue?

    Many thanks.
  2. plinden macrumors 68040


    Apr 8, 2004
    Do you have WPA enabled on the router? If so try disabling it (temporarily) and see if that helps.

    With WPA enabled, see if there are any dropped packets (open Network Utility, click on the ping tab, enter eg. www.google.com and set ping count to 100).

    I had an iMac that had an awful wireless speed, even lower than you're seeing, when connected to a Netgear router with WPA enabled. Several other Macs and PCs had no problems. The problem was only with that router, and went away when I connected the iMac to the router AT&T gave me when I got U-verse.
  3. MacMiniBoy thread starter macrumors newbie

    Apr 28, 2009
    Absolutely correct. With WPA disabled, the speed difference is staggering.

    obviously can't leave my wifi unprotected though. Any ideas?
  4. Lance-AR macrumors 6502

    May 7, 2012
    Little Rock, AR
    If it is still problematic after today's update, you might be stuck having to use an Ethernet cable for now.
  5. MacMiniBoy thread starter macrumors newbie

    Apr 28, 2009
  6. jollyreaper macrumors regular

    Oct 25, 2011
    My wireless performance on my mini has been getting progressively worse since I've owned it. Today it's to the point where the mini is ruining network speeds for everyone else in the house.

    Originally had ATT DSL, now U-verse. Sometimes I'm getting full bandwidth, other times it's slowed to a crawl. Right now it's barely pulling 10k/sec.

    What's the update you're referring to?
  7. Lance-AR macrumors 6502

    May 7, 2012
    Little Rock, AR
    Hah, I'm not sure. It might have been 10.7.4.
  8. McGilli macrumors 6502

    Nov 11, 2008
    MAC Address control.
  9. MacMiniBoy thread starter macrumors newbie

    Apr 28, 2009
    Do you think a USB wifi dongle would resolve this? And disable the onboard wifi?
  10. jollyreaper macrumors regular

    Oct 25, 2011
    I just bit the bullet and got an ethernet-over-wall-socket adapter for the house. Plug in end A in the computer room, plug in end B in the living room. Works like a charm, performance is better than ever. Apple FAIL, ether-over-socket WIN.
  11. EssEye macrumors newbie

    Jul 19, 2012
    I faced frequent WiFi connectivity issues, not with the Mini but with my iMac (27-inch, late 2011 model).

    My Motorola Docsys modem and Apple TimeCapsule router/backup are on the 2nd floor and my iMac is in the basement (where there is no Ethernet connection).

    After spending hours researching the subject, I finally got the Actiontec Powerline Network Adapter Kit PWR 500 from Best Buy a few weeks back for $50.

    It solved my intermittent WiFi connectivity issue but the problem is I can't change the factory Encryption Keys on the Actiontec 500.

    Bottom line, if changing Encryption Keys is not a big deal for you, you can try the Actiontec 500 Powerline Network Adapter Kit.

    My Toys - iMac (27-inch), iPad 2, iPhone 4, iPod mini
  12. dotcomet macrumors member


    Dec 23, 2011
    I've never had any good luck with D-Link routers. I have gone through a few different brands and after much research and trial and error, the Airport Extreme has been by far the best performing router I have ever purchased.

    However, have you tried changing the Wifi channel on the D-link? Most of the time, the default channel is either channel 6 or 11 and it is automatically set. You could change the channel to see if you get better performance. My guess is that you may not see a significant difference.

    One other thing. Have you deleted the Wifi connection on your Mini? I'm sorry, I didn't read all the responses, so I don't know if you did this.

    Deleting the Wifi connection and then adding a new Wifi connection may also help.

    Relocating your router to a higher level may also help. Cordless phones and Cell phones also cause interference which can affect performance.

    Finally, upgrading your router firmware may help.
  13. hfg macrumors 68040


    Dec 1, 2006
    Cedar Rapids, IA. USA
    This is a pretty old post by the OP ... however ...

    Your problems might be related to poor WiFi antenna radiation from the Mac Mini. You might try temporarily setting it on its side, and in a higher location away from your monitor, etc. The same goes for your wireless router ... put it in a clear high spot for best antenna radiation.

    If that works better, you could consider either relocating it in a better spot, or using a USB WiFi adapter which you could put on a cable and mount in a higher location (many laptop models come with a small stand for just that purpose). Or get one designed for fixed desktop use with a cable and set it on top of your monitor. :)

    There is also, of course, the possibility that the Mac WiFi just doesn't work well with your wireless router brand. :(

    I assume you have already tried changing the channel to avoid interference from neighbors on the same channel.

  14. mwhities macrumors 6502a

    Jul 13, 2011
    Airport Extreme (G4) with everything in sig.

    I haven't had any issues with my wireless (same Mac Mini as OP). Running Lion too. I did add the 5ghz wireless last night and it improved even more.

    Not much to say that will help, just stating I have the same model and it's working fine. Maybe something with the Airport card?
  15. Jackintosh macrumors 6502a


    Mar 21, 2009
    I'd check the DSL modem's signal levels. I know with a cable modem, S/N should be 35db or higher, and power level leass than 52db.

Share This Page