Popup for iCloud password at each reboot

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by arnoz, Mar 24, 2015.

  1. arnoz macrumors regular

    Joined:
    Jun 20, 2007
    Location:
    Lausanne
    #1
    Since recently, whenever I reboot my Mac, as soon as I land on the Finder I have a popup asking me for my iCloud password:
    [​IMG]

    If I enter my password, it just keeps on coming. I gave up after 5-6 attempts. If I click on cancel, it appears once more then disappears.

    All iCloud services are running properly though. I am logged in, I can see everything properly in System Preferences, my emails are working, my tabs/favorites are synced etc.

    What could this popup be and how to stop it from appearing? Thoughts?
    Thanks
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Try finding that iCloud entry in Keychain and delete it then restart and enter the PW again. Often that will make it stick in Keychain and fix this.
     
  3. Baytriple macrumors 6502

    Joined:
    Apr 3, 2012
    #3
    Funny you write this. My machine has just started to do this. I did the same as you. I just put it down to somebody else using my work machine. It would be interesting to see what comes of this.
     
  4. Photography macrumors 65816

    Photography

    Joined:
    Apr 10, 2007
    #4
    The same exact thing has been happening to me. I click on the cancel button a few times and it goes away, but if I keep typing my password in, it keeps reappearing.
     
  5. TheBogeyMan macrumors newbie

    Joined:
    Nov 12, 2013
    #5
    I just finished fixing this too. Since my iMac is new I was able to get Apple Support to assist me in resolving the issue.

    I didn't keep copious notes, but basically here's what "I" did:

    1. Sign out of Messages.
    2. Sign out of FaceTime.
    3. Completely sign out of iCloud (SysPrefs, iCloud). You might need to do this a couple of times. Select all the defaults when you're prompted.
    4. Reboot.
    5. Open Keychain Access.
    6. Delete all entries related to Messages (search for "Message").
    7. Delete all entries related to FaceTime (search for "FaceTime").
    8. Delete all entries with "ids".
    9. Reboot.
    10. Sign back into iCloud.
    That fixed it for me. I was then able to send/receive messages via Messages and have functioning FaceTime conversations.
     
  6. Baytriple macrumors 6502

    Joined:
    Apr 3, 2012
    #6


    Thanks for taking the time to give your thoughts. I'm going to give that a go.
     
  7. Jamesk811 macrumors 6502

    Joined:
    Mar 23, 2015
    #7
    This is a two step verification issue. You need to go to "manage my Apple ID" on the web and create a two step verification password for messages app.
     
  8. arnoz thread starter macrumors regular

    Joined:
    Jun 20, 2007
    Location:
    Lausanne
    #8
    Sorry for the late feedback guys. Unfortunately I tried both options, the step by step followed by a reboot or the creation of an App specific password unfortunately none worked :(
    I just rebooted and had the popup again.
     
  9. Jamesk811 macrumors 6502

    Joined:
    Mar 23, 2015
    #9
    I updated to the latest OS X 10.10.3 beta and noticed the issue stopped for me. I don't know whether it was due to setting an app specific password or if it was simply updating to the latest beta but thats what did it for me.
     

Share This Page