PORT 3689 error - new Apple TV

Discussion in 'Apple TV and Home Theater' started by MacHound, Dec 25, 2008.

  1. MacHound macrumors newbie

    Joined:
    Sep 20, 2008
    #1
    Ok. Here's the deal. Husband is trying to install and run Apple TV on his Dell laptop with Windows Vista. We are about to throw it out the window because we can't figure out what to do about this firewall. I have followed all of the instructions that Apple provides.....but there doesn't seem to be much about Vista.

    I use a Mac, and asked if he just wants to set it up on here, but no. So we continue.

    We have done everything but totally turn the firewall off -- any other advice? The closest Apple store is 3 hours away and we just want this to work!

    I've tried adding the port, allowing incoming connections through the firewall, etc. What am I doing wrong?!
     
  2. sdalporto macrumors newbie

    Joined:
    Mar 30, 2006
    #2
    on my router, I had to remove the check mark for 'Filter Multicast'. Maybe you can check and see if your router also has this option.
     
  3. moniquetx macrumors member

    Joined:
    Sep 25, 2008
    Location:
    Dallas, TX
    #3
    I've been having the same problem on and off for the last two months but tonight I decided to deal with it.

    Two things to try:

    1. Restart the Apple Mobile Device Service (AMDS) on Windows XP and Vista

    http://support.apple.com/kb/TS1567

    2. Connect your Apple TV through Ethernet to the laptop (because when you originally sync this way is so much faster than Wi-Fi) and then go to command prompt and type

    netsh int ip reset log.txt

    Wait a couple of minutes close and re-open iTunes. Then re-enable syncing with your Apple TV from the Preferences tab. Disable you Wireless network connection and watch as your Apple TV magnificently syncs your content :)
     
  4. moniquetx macrumors member

    Joined:
    Sep 25, 2008
    Location:
    Dallas, TX
    #4
    What router is that?
     
  5. sdalporto macrumors newbie

    Joined:
    Mar 30, 2006
    #5
    Linksys WRT54GL that is running DD-WRT v24-sp1
     
  6. wolfmedic macrumors newbie

    Joined:
    Mar 29, 2009
    #6
    Sorry for bumping, but after several days of getting frustrated with syncing my pc to the atv, I believe I figured out how to do it.

    First of all, I noticed that everything except for movies would transfer over wirelessly, no problem there. When I tried to sync movies, I would get the 3689 port error.

    After searching the web, and being told by Apple that it couldn't be done with a pc via ethernet, I was on the verge of returning it.

    Then it hit me. If the atv could connect via ethernet to my router, and go online that way. What if I connected my laptop to the same router via ethernet as well. Obviously you would need a router with multiple ethernet connections.

    Voila. My movies synced over in no time at all, with no errors and no hesitation. My Apple Tv is now fully functional, although I just have to remember that I need to wire my laptop in before syncing big files.

    I hope this helps, and if it is already common knowledge, then my apologies.
     
  7. Equality7251 macrumors newbie

    Joined:
    Aug 9, 2009
    #7
    My solution is below - some preamble first for those despairing as I was!

    I had exactly the same issue - purchased ATV yesterday to add to my iMac with Time Capsule WiFi network setup. ATV connected perfectly to the Web but I could not get it to sync with my iMac's iTunes library. I wanted to stream rather than sync but couldn't do either. Tried all previous suggestions - PRAM resets, Firewall to "Allow all incoming connections", router changes - all to no avail.

    Console utility was reporting in its logs that my iMac was denying the ATV access.

    I'm lucky enough to be friends and neighbours with an excellent network admin who deals with Macs as well as PCs but we still couldn't figure it (I'm an SQL DBA so know a little about networks too). He also has ATV and streams with no problem and had no installation or configuration issues.

    We wirelessly connected my ATV to his iTunes library and it worked first time, streaming like a dream. This ruled out ATV as the issue and put my iMac completely in the frame; we still couldn't coax mine into accepting comms from ATV.

    Finally tried the NoobProof freeware utility. I used it to specifically set port 3689 to "Allow" i.e. wipe out any existing settings and set the damn thing to "Allow". Bingo. Everything now works.

    It could be something I've done over the past 18 months since I switched to block that port so I cannot point blame at the iMac or ATV.

    Now it's working I have to say I think ATV is just superb, another quality product from Apple (I didn't think that way about 24 hours ago though!).

    Take-away: if you're still getting the 3689 error then please try the NoobProof util (or something similar like WaterRoof) to at least rule out a genuine firewall rule is blocking the communication.

    I hope this helps someone - when I was tearing my hair out I found plenty of reports of this problem but not too many suggestions. Please write how you get on and any success you have with this really frustrating problem. Best of luck.
     
  8. deaconclaire macrumors newbie

    Joined:
    Aug 23, 2009
    #8
    Thanks for the advice - it works!

    :)I had tried everything (short of reformatting the Apple TV as I couldn't bear the thought of possibly losing everything - I'm a non-techie) - but after downloading and installing NoobProof, it all finally was up and running again and appears to be syncing as normal. Phew!
     

Share This Page