Port forwarding problem with Transmission!?

Fallinangel

macrumors regular
Original poster
Dec 21, 2005
144
0
Hey MacRumors,

Yesterday, I've got my internet connection upgraded to fibre. My ISP also replaced my old Linksys router with a newer Fritz WLAN 7390. However, now port forwarding isn't working anymore!

I usually have no problems configuring networked stuff, but I can't seem to figure out the problem this time.
I've configured a static internal IP - 192.168.178.33 - for my computer:



I've also enabled UPnP on the router. I know that it's not the safest option, but it's usually pretty practical.



The router does also open the right ports for Transmission when I open the torrent client. Transmission doesn't recognise the opened ports though!



Furthermore, I've tried configuring the ports manually with TCP and UDP, but unfortunately that doesn't work either.
I think that the problem might be caused by the new internet connection, which has IPv4 and IPv6 enabled.



I don't know enough about those "protocols" to figure out a solution on my own.
Any ideas? :(
 
Last edited by a moderator:

killerrobot

macrumors 68020
Jun 7, 2007
2,218
0
127.0.0.1
I'm not familiar with that router, but in the second photo it says "No port forwarding has been enabled". Instead of trying the UPnP setup, try creating a new port forwarding to see if that will fix your problem.
 

Fallinangel

macrumors regular
Original poster
Dec 21, 2005
144
0
I'm not familiar with that router, but in the second photo it says "No port forwarding has been enabled". Instead of trying the UPnP setup, try creating a new port forwarding to see if that will fix your problem.
As already mentionned im my first post. I've tried configuring the port manually, but that doesn't work either
 

killerrobot

macrumors 68020
Jun 7, 2007
2,218
0
127.0.0.1
As already mentionned im my first post. I've tried configuring the port manually, but that doesn't work either
According to the transmission forums there should be no problem with IPv6 addresses and peer sharing. https://forum.transmissionbt.com/viewtopic.php?f=1&t=9138

I think checking the box that says "Allow changes to security settings over UPnP" still doesn't forward the port in the first place: it would just accept the incoming connection without question. Again, I'm not familiar with the modem, but that's my interpretation.

As far as you manually setting the port forwarding, your photo states otherwise. I'm suggesting forwarding the ports here:
 

Attachments

Last edited:

Fallinangel

macrumors regular
Original poster
Dec 21, 2005
144
0
I've tried it, but it still doesn't work.



It's annoying, but I think that I won't find a solution.
 

killerrobot

macrumors 68020
Jun 7, 2007
2,218
0
127.0.0.1
I thought for sure that would fix it. The only other thing I can think of is to check that it isn't being block by your mac's firewall.
System Prefs>Security>Firewall tab
If Transmission shows block all incoming connections click it to accept and hopefully that will fix it.

I'd also try another Torrent App to see if it can connect on the same port or not. It might just be something weird going on with Transmission at the moment.
 

Attachments

Last edited:

WesCole

macrumors 6502a
Jul 1, 2010
756
12
Texas
Is it possible your new Internet connection is blocking p2p traffic? I had similar issue with ports saying they were blocked/unavailable and it turns out it was the VPN I was connected to not allowing p2p traffic.
 

Fallinangel

macrumors regular
Original poster
Dec 21, 2005
144
0
I thought for sure that would fix it. The only other thing I can think of is to check that it isn't being block by your mac's firewall.
System Prefs>Security>Firewall tab
If Transmission shows block all incoming connections click it to accept and hopefully that will fix it.

I'd also try another Torrent App to see if it can connect on the same port or not. It might just be something weird going on with Transmission at the moment.
The native firewall isn't enabled. I see no point in it!
I'm pretty sure that my problems stem from mixed IPv4 and IPv6 traffic.

Is it possible your new Internet connection is blocking p2p traffic? I had similar issue with ports saying they were blocked/unavailable and it turns out it was the VPN I was connected to not allowing p2p traffic.
I don't think that my ISP is blocking P2P traffic. My home country isn't exactly known for strict policies. I've been with the same ISP for over a decade now and there has never been any blocking or censuring of.
Furthermore, I don't use a VPN or any other proxy.

Have you tried a Port Scan? Are you using IPv6 for anything? If not turn it off on your Mac.
Port Scan states that the TCP for 53558 is open, when I make it scan my IP (192.168.178.33) for open ports.
However, when I scan (192.168.178.1) the router, it doesn't even find the the port. I'm not sure if that plays any role though.

In fact, my router is set to use IPv6 as a native connection.
I think that the port forwarding issues stem from the mixture of IPv4 and IPv6, since both connections are enable by the router.
How can I disable IPv6 on my mac without having to shut it down on the router?
 

kryten2

macrumors 6502a
Mar 17, 2012
996
59
Belgium
How can I disable IPv6 on my mac without having to shut it down on the router?
You can turn it off on the mac without having to shut it down on the router. Don't know if this will help but it doesn't hurt to try. You can allways turn it on again.
 

Attachments

Fallinangel

macrumors regular
Original poster
Dec 21, 2005
144
0
You can turn it off on the mac without having to shut it down on the router. Don't know if this will help but it doesn't hurt to try. You can allways turn it on again.
Hm, that doesn't seem to be an option for me!?

 

Fallinangel

macrumors regular
Original poster
Dec 21, 2005
144
0
If you're running Lion you'll find how to turn it off by looking at posts #6 and #7 in this thread http://forums.macrumors.com/showthread.php?t=1250993.
Don't know if it's the same on ML. I"m still running Leopard.
Thank you for all your help, kryten 2!
Although, I managed to turn IPv6 off in Lion, the ports remain closed.
I give up, but thanks for the great support you guys. :/
 

kryten2

macrumors 6502a
Mar 17, 2012
996
59
Belgium
One last thing you can do is to ask a friend or someone you know to do a portscan of your public IP with Nmap.