Portable Hard Drive not working with USB Hub?

Discussion in 'Mac Accessories' started by bestMBP15, Aug 31, 2010.

  1. bestMBP15 macrumors newbie

    Joined:
    Aug 31, 2010
    #1
    I recently purchased this Portable (iomega) 500GB hard drive. I just realized it only works on my Mac's USB ports, but not with my USB Hub...

    Does it exceed the power limit of the USB Hub? I don't see how it is possible, because I currently have nothing else plugged into it, and it uses a power adapter.

    It worked with my old Hard Drive, which is big and uses a power adapter. Now it doesn't seem to work. Also I tried on just a USB adapter that makes the cable longer, still doesn't work. Only the MBP ports work!

    However, the hub works for things such as phone charger, and speakers right now.

    What is the problem??

    Thanks.
     
  2. AppleNewton macrumors 68000

    AppleNewton

    Joined:
    Apr 3, 2007
    Location:
    1 Finite Place
    #2
    sounds like a power consumption issue.
    Does your USB hub have a power adapter itself?
    If its just running straight to the MBP on the MBP's USB port then yeah you will run into power consumption issues.

    I would find a different USB Hub that has a power adapter, or even one that can supplement the proper power...otherwise a FireWire drive if you have those ports available on your system.
     

Share This Page