Portal 2 incompatible with new iMac

Discussion in 'iMac' started by johncozen, May 4, 2011.

  1. johncozen macrumors member

    Joined:
    Feb 5, 2010
    #1
    I purchased the new iMac launched this week and it has a custom OSX build 10.6 that will not update to 10.6.7 and I am unable to launch my Steam copy of Portal 2 because Steam prevents the game from launching and an alert box appears saying Portal 2 requires 10.6.7. Anyone got a fix? (tried the combo update, won't install)
     
  2. treebark7182 macrumors member

    Joined:
    Mar 16, 2011
    #2
    whoa bummer, I was looking forward to playing that when mine came in :(
     
  3. MR.Raul macrumors regular

    MR.Raul

    Joined:
    Jul 28, 2010
    Location:
    Sweden
    #3
    Me too!

    Is almost the pure purpose of me buying the high end 27"
     
  4. xkmxkmxlmx macrumors 6502a

    xkmxkmxlmx

    Joined:
    Apr 28, 2011
    #4
    Why won't it update to 10.6.7? I am confused.
     
  5. Dute macrumors member

    Joined:
    Mar 15, 2011
    #5
    I assume it's a custom build for the new SB processors. Likely see an update within the next week to bring them all to the same build.
     
  6. Nishi100 macrumors 6502a

    Joined:
    Mar 27, 2010
    #6
    Isn't there a way to change one of the plist files, which will make the info box say it's 10.**
     
  7. turbobass macrumors 6502

    Joined:
    May 25, 2010
    Location:
    Los Angeles
    #7
    May be because 10.6.7 has different drivers for the 3D acceleration? Still, don't understand why it won't update...there's your problem right there!
    :eek:
     
  8. bendodson macrumors member

    bendodson

    Joined:
    Jul 12, 2008
    Location:
    UK
    #8
    Got it working on the new iMac

    I managed to get it working on my new 27" iMac by editing a system file to fool Steam into believing that you are running 10.6.7 - I believe the 10.6.7 requirement is because of new ATI graphics drivers that were bundled with that release and therefore this is quite safe (as the 10.6.6 build on the new iMacs obviously has the drivers for the machine).

    I've posted the full details at http://bendodson.com/weblog/2011/05/04/portal-2-on-the-new-imac-10-6-6/ but basically you need to change the SystemVersion.plist file in your /System/Library/CoreServices/ directory so that the two references to 10.6.6 are changed to 10.6.7 - Steam will still complain but when you say "continue anyway" it'll actually run.

    Enjoy!
     
  9. johncozen thread starter macrumors member

    Joined:
    Feb 5, 2010
    #9
    Nice, hope this works on my machine too, and doesn't eff up anything else.
     
  10. reclusive46 macrumors 65816

    reclusive46

    Joined:
    Apr 14, 2011
    Location:
    Canada
    #10
    Thats annoying but I'm sure they'll release 10.6.7 soon on the iMac.
     

Share This Page