Portal crashes after "anvil" and "Powered by Source" windows disappear

Discussion in 'Mac and PC Games' started by Macrovertigo, May 29, 2010.

  1. Macrovertigo macrumors member

    Macrovertigo

    Joined:
    Jan 25, 2008
    Location:
    Vermont/España/etc.
    #1
    I am new to games period, so I wonder if I am just missing a step.
    I have a Steam account, and have Steam and Portal downloaded (a few days ago when it was offered for free).
    When I click on the Play Portal button in Steam games library (using my 2009 Mac Pro using OS 10.5.8), a Portal icon opens and bounces in the dock and the two Steam windows open, then they close, icon disappears in mid-bounce, and nothing that I can find starts the game although Steam continues to be open. I can take or leave Portal, but I would like help to find out what I am doing wrong before I buy and try to play the game I am interested in, thanks.
     
  2. Washac macrumors 68020

    Washac

    Joined:
    Jul 2, 2006
    #2
    Hi

    I use a 2009 Mac Pro and Portal works OK here.

    Lets go step by step....

    1. You open Steam and it all boots OK into your account ?
    2. You then go to Library > Games within Steam and click the Play Portal button?

    You have to play the games within Steam, not have Steam open and try to open the games outside of Steam.
     
  3. Macrovertigo thread starter macrumors member

    Macrovertigo

    Joined:
    Jan 25, 2008
    Location:
    Vermont/España/etc.
    #3
    Hi yes I
    1) open Steam and it all boots into my account, and
    2) I click the Play button for Portal in Games, in Library.
    The Portal icon bounces in dock for a moment and then disappears, Steam continues to run.
    -(this is on a Mac Pro runnin OS 10.5.8, GT 120 card)
    I have been able to play once before, Portal or Steam knows that I played ninety minutes on one occasion, but thinks that my other failed attempts to play again have been further play episodes - everytime I attempt to re-login for play it tells me I was just playing.
    hmm.
     
  4. Macrovertigo thread starter macrumors member

    Macrovertigo

    Joined:
    Jan 25, 2008
    Location:
    Vermont/España/etc.
    #4
    Portal now plays as it should, probably thanks to updates or something

    Well the problem has resolved itself, thanks. I think it had to do with updates from Steam or something finally taking hold.
     

Share This Page