portal - not rendering through portals on i7 imac

Discussion in 'Mac and PC Games' started by wilycoder, May 13, 2010.

  1. wilycoder macrumors 6502

    Joined:
    Aug 4, 2008
    #1
    I just get a black looking portal, it doesnt render the contents of the portal.

    Anyone else have this issue on the 27" imac with ati 4850?
     
  2. NGL macrumors member

    Joined:
    Feb 28, 2010
    #2
    This happened to me today after portal patched itself, it was fine before that.

    -Nick
     
  3. Wallace macrumors member

    Wallace

    Joined:
    Oct 9, 2003
    Location:
    Michigan
  4. gatepc macrumors 6502

    gatepc

    Joined:
    Apr 11, 2008
    Location:
    Pittsburgh PA
    #4
    Same here portal worked fine until they put out the patch today now all I see when I look at a portal is blackness.... Patches are supposed to fix things not break them...
     
  5. jedivulcan macrumors 6502

    Joined:
    May 15, 2007
    #5
    Same... two different machines tested here with black Portals... 9600m and 9400m are a no go.
     
  6. aiqw9182 macrumors 65816

    Joined:
    Apr 22, 2010
  7. kc2dpt macrumors newbie

    Joined:
    Aug 8, 2007
    #7
    Same. Macbook Pro Intel. Worked before the patch.
     
  8. Xavier macrumors 68020

    Joined:
    Mar 23, 2006
    Location:
    Columbus
    #8
    rbarris works for value? I thought you worked for Apple.. or blizzard?
     
  9. yoitsmike92 macrumors newbie

    Joined:
    Apr 17, 2010
  10. theARNSKI macrumors regular

    Joined:
    May 27, 2009
    #10
    I noticed this as well.

    Trying the work around right now....

    EDIT: the work around fixed it for me
     
  11. Sambo110 macrumors 68000

    Joined:
    Mar 12, 2007
    Location:
    Australia
    #11
    This happened to me once yesterday, but stopped when I restarted the game.
     
  12. Vertigo50 macrumors 65816

    Vertigo50

    Joined:
    Apr 11, 2007
    #12
    Thanks for posting the fix. That totally worked for me. I hope they get it patched, though.
     
  13. matttung macrumors member

    Joined:
    Apr 17, 2010
    Location:
    HK
    #13
    Same here.. it's after the patch
    I first thought it was blackened to make further stages harder - seems like it's not!
     
  14. C. Alan macrumors 6502

    Joined:
    Jan 23, 2009
    #14
    The fix posted above did not work for me (early 2009 Mac Pro), but turning off color correction in the advanced video setting did fix it.
     
  15. savar macrumors 68000

    savar

    Joined:
    Jun 6, 2003
    Location:
    District of Columbia
    #15
    I guess they should have had more beta testing time. How did such a huge bug slip through QA?

    Before the patch, I was able to play on the IGP with portals, but the discrete graphics would not render the portals.

    After the patch it was broken on both GPUs.

    Still, I won't complain too much about a free game; still if I had paid money for this I would be livid.
     
  16. kc2dpt macrumors newbie

    Joined:
    Aug 8, 2007
    #16
    Restarting in windowed mode made the portals render correctly.
     
  17. PharmD macrumors 6502

    Joined:
    Aug 2, 2005
    Location:
    Oregon Coast
    #17
    Phew, that fixed it. That made the game much harder lol.
     
  18. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #18
    He used to be at Blizzard and is now at Valve.

    Edit: And I just relaunched the game and it downloaded an update, and now I have black portals too. I'm not really interested in messing around with settings [Edit 2: But I will anyway]; how do I revert to the old version?

    And for that matter, how do I stop it from auto-updating in the first place? After this issue I'd like to do some reading before installing any more updates.
     
  19. DanielMyst777 macrumors member

    Joined:
    Jan 30, 2009
    #19
    fame rate downgrade

    As far as the black portals go, I am also experiencing it as well, but I have also noticed a drastic performance decrease in frame rate! :mad: I used to be getting little to no lag during the game on my settings, now I get lag with every portal I see and with special effects. This sucks :( Hope they get the update out soon.
     
  20. allfunandgames macrumors member

    Joined:
    Mar 24, 2010
    Location:
    Auckland, New Zealand
    #20
    Hey kids - Valve have released an update that apparently fixes the Black Portal problem:

    Portal Update Released
    Product Update - Valve
    Updates to Portal have been released. The updates will be applied automatically when your Steam client is restarted. The major changes include:

    - Fixed Portals being black rather than see-thru
    - Fixed crash when exiting
    - Fixed crash when using keyboard inside of key binding dialog


    I'm impressed with how quick they have gotten the issue resolved!
     

Share This Page