Portforwarding & Soulseek

Discussion in 'Mac Basics and Help' started by sayre, May 13, 2009.

  1. sayre macrumors member

    Joined:
    May 4, 2009
    #1
    I am trying to port forward for soulseek, now when i had my windows computer, everything was forwarded...

    I can't seem to get it right on my iMac, i've looked at the portforward website and i am somewhat familiar with it...I use D-Link DI-604 Router, went into system preferences within the mac, copy and pasted the router ip, into the spaces provided, my default listening port is 2234....so basically i have:

    Name: Soulseek1
    Private IP: 192.168.0.1
    Protocol Type: TCP
    Private Port: 2234
    Public Port: 2234
    Schedule: Always

    can anyone please help? what am i doing wrong here? Thank you.
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    You want to forward the port to your machine IP, not the router IP. It sounds like you have the router set to forward the port to the router, which is a loop at best. Unless I missed something.
     
  3. sayre thread starter macrumors member

    Joined:
    May 4, 2009
  4. sayre thread starter macrumors member

    Joined:
    May 4, 2009
    #4
    ok i just changed it to my personal ip, shut down my computer, tried a user i normally connect with and it said 'unable to connect, waiting for them to connect to us' hmm...:confused:
     
  5. sayre thread starter macrumors member

    Joined:
    May 4, 2009
  6. RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #6
    Well, if you have shut down your computer, then no, it's still not going to work

    Also, does your computer have a manually set private IP address? A DHCP reservation? If you have a dynamic address, then you will need to change the forward everytime.
     
  7. sayre thread starter macrumors member

    Joined:
    May 4, 2009
    #7
    yes i have a manually set private ip (it's always the same), i don't know what dhcp reservation is and or dynamic address?
     
  8. sayre thread starter macrumors member

    Joined:
    May 4, 2009
    #8
    ok i'm not getting anywhere, let's try this again...

    This is how i have it set-up currently, which doesn't seem to work:
    Name: Soulseek1
    Private IP: 192.168.0.234
    Protocol Type: TCP
    Private Port: 2234
    Public Port: 2234
    Schedule: Always

    I went to System Preferences>Network>Ethernet

    Configure: Using DHCP (this is what it is set to, i have no idea what DHCP is)
    IP Address: 192.168.0.xxx (let's just say this xxx = 234 for the time being)
    Subnet Mask: ...etc
    Router: 192.168.0.1

    Ok, so i went to portforward.com>selected router>d-link di-604>soulseek.
    I noticed something however, when i hover over my username in soulseek and click "get IP address" it'll say something like "98.334.69.233" however, when i go to system preferences>network>ip address its something like "192.168.0.234" I'm a bit confused by these, which ip address do I use? (note: both of these ip addresses are not the router as the router is 192.168.0.1, i believe)

    I have 3 computers hooked up to this router. Thanks.
     
  9. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #9
    192.168.0.1 = Local router IP
    192.168.0.234 = Your machine IP on local network
    98.334.69.233 = Your residence IP assigned by your internet provider (which can change over time)

    DHCP = Dynamic Host Configuration Protocol. It helps automatically assign IP addresses to machines on the network.

    I have my MacBook setup with a static IP, which required me to ignore the DHCP to setup correctly. Make sure you have your machine's static IP setup correctly. Also, you may want to try a different static address. Currently you're using .234 so you could try .58 or .145. The router may only only a certain range for the address.

    I've never used Soulseek or your brand of router. I've never needed to forward ports for anything other than a web server, ftp server, and SSH ports.
     
  10. sayre thread starter macrumors member

    Joined:
    May 4, 2009
    #10
    ok i configured it manually followed all the guides on portforward.com, assigned a static ip address (restarted the computer) and i'm still unable to get a connection on slsk with the users i normally connect to...this is quite frustrating.

    edit: i was just curious, so i checked my brothers computer (windows), it is utilizing uPnP (automatic port forwarding) and i checked his port and it does say open, is there anyway to establish uPnP on a mac? On the windows slsk version it has this option in the general options settings, however on the mac version, i don't see this.
     
  11. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #11
    I don't think you adjust that on your Mac. My router has an option to enable/disable UPnP.
     
  12. sayre thread starter macrumors member

    Joined:
    May 4, 2009
    #12
    hmm well checked my router settings and uPnP is enabled... :confused:
     
  13. sayre thread starter macrumors member

    Joined:
    May 4, 2009
    #13
    UPDATE: problem solved, after looking at this guide http://trac.transmissionbt.com/wiki/PortForwardingGuide I began to realize that maybe my issue was a firewall problem, since I followed everything exactly on portforward.com, basically i had to go to system preferences>security>firewall>set access for specific services> +>add slsk as well as utorrent> allow all incoming connections, then restart and it worked. :D
     

Share This Page