POSIX Error

Discussion in 'MacBook Pro' started by iiBenxD, Dec 26, 2010.

  1. iiBenxD, Dec 26, 2010
    Last edited: Dec 26, 2010

    iiBenxD macrumors newbie

    Joined:
    Jun 26, 2010
    #1
    I'm honestly quite annoyed right now. I've had my Momentus XT in my Macbook Pro 13" (mid-2009) for about a month now, and it failed. I didn't change the way I used the laptop as opposed to the OEM hard drive that I had in there previously. I use my laptop at school, so I put it in my backpack, and I'm very careful that I don't bang it around.

    Anyway, I opened it when I got home (I just shut the screen and put it in sleep mode), and it was being extremely slow. So I decided to reboot it, which turned out to be a bad idea.

    It like, wouldn't start. It made the normal chime, and then went to the Apple logo loading screen and hung there for 15 minutes, so I tried to boot into my Windows partition. It hung for a few seconds and then gave me a screen that I'm assuming means it cannot find the partition. It looked like a folder with a question mark on it.

    I started the computer from my SL install disk and opened Disk Utility, hoping to just reformat my drive and start fresh. For some reason though, it wouldn't format. It gave me that darn "POSIX: Cannot allocate memory." error whenever I tried to format it. And for some reason, my computer would boot from GParted, so I gave up on that.

    I just came back from Best Buy with a SATA to USB adapter, and hooked up the hard drive to my other laptop. It mounted properly (in both Windows and Ubuntu), and I was able to format it. So I put it back into my MBP after formatting it twice, and it still gave me the POSIX error. So I just tried taking it out of the laptop and booting the SL install disk without a hard drive inside of it. Instead, I connected the hard drive through the SATA to USB adapter and formatted it. Well, for some reason, it worked... I guess there's a difference between how it reads when it's seen as an external hard drive.

    Anyway, I formatted it with the GUID partition table and am now installing OS X onto it, as an external hard drive.

    If that installation finishes and boots, I'm going to put the hard drive back into the computer and see if it will format again (just for safe measures).

    Anyway, the point of this thread is to show my experience with the POSIX memory allocation error that I've seen other people having in the past, and I've never seen someone be able to fix it. So hopefully this fix will work. If it does, I'll post a less confusing version of what I said above later.

    Any feedback would also be welcome. Thanks :)
     
  2. iiBenxD thread starter macrumors newbie

    Joined:
    Jun 26, 2010
    #2
    Okay, so it finished installing, and I tried booting from the external hard drive and it worked fine. So that leads me to the conclusion that there is nothing wrong with the hard drive.

    I just put it back into my laptop, and I'm getting the same error again. It won't boot from OS X, and Disk Utility gives me the same POSIX error. So this leads me to believe that my laptop is just fried... is this true? Has anyone ever had this error before?

    Thanks ~
     
  3. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #3
    It's possible you have a bad HD cable in the laptop. We see a lot of unibodies w/bad HD cables.
     

Share This Page