Possible 3.1.3 GPS issues on 3G?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by outcastrc, Apr 4, 2010.

  1. outcastrc macrumors member

    Joined:
    Jun 15, 2009
    Location:
    BC, Canada
    #1
    I have been trying to figure something out. I use my GPS a lot, and for the most part my iphone has done a spectacular job tracking itself. I recently updated to 3.1.3 and I think it might have messed something up (not 100% sure on the timing) The last couple weeks my GPS has had a mind of its own. It seems to randomly jump between GPS, triangulation, and no signal. In a 30 minute drive since I have been tracking it, it will trip up sometimes up to 3 times, sometimes none... At its worst I may make it 3 blocks before I get an update. Some times it will update a few times per block, then for no apparent reason it goes back to updating constantly. Tracking when on GPS is still spot on, triangulation is garbage but at least gets me within a block or two of my location.

    I have tried Gmap, google maps, motion x, trapster and they are all doing the same thing. So I gather its the API thats the problem.

    I have tried resetting, reinstalling apps, restoring from back up, restoring as new, and its still the same. I was about to try to reinstall 3.1.3 again to see if that does anything. The truck mount hasn't moved so its in the same spot as its been for a year.

    I do have extended warranty on the phone but they want to ship the phone off out of town and can't give me a time frame as to how long the phone will be gone. They won't give me a loaner, and if they feel its a software problem they'll just ship it back. So I am hesitant to hand it over.

    Hunting on the net for iphone issues brings up a zillion hits but nothing that fits my exact problem that I can see. Thought I would see if anyone has any ideas.

    Thanks...
     
  2. PunkRockPete macrumors newbie

    Joined:
    Jul 11, 2008
    #2
    Me too

    You described my problem perfectly. A white 16gb 3G, with exactly the same issue. Unfortunately, I am far out of warranty. Hopefully someone can help.
     
  3. outcastrc thread starter macrumors member

    Joined:
    Jun 15, 2009
    Location:
    BC, Canada
    #3
    I have managed the last two trips to work fine. If todays trip is ok I am going to cancel my warranty repair.

    After reading for hours on apple forums I tried another go around. I reset everything I could (network, location, airplane mode, etc...) settings after I restored yet again and so far it seems to be working.

    Go figure...

    I do wish there was a way to better diagnose these type of issues...
     

Share This Page