Possible Battery Problem

Discussion in 'iPod touch' started by JoeShades, Jul 25, 2015.

  1. JoeShades macrumors 6502a

    Joined:
    Sep 1, 2010
    Location:
    Williamstown, NJ
    #1
    I finally got my Ipod touch today, it was only 50% of battery left so i charged it after using it for awhile. When i charged it the battery was down to about 15% , i have had it plugged in now 3 hours and i am confused about something. When my ipod 4 was fully charged the icon up top went from a lightning bolt to a plug, but after 3 hours i still see a lightning bolt up top near the battery indicator. Is there a problem or is this the way it is for this version??
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    It is normal to get new devices out of the box with the battery on a partial charge.
    This could simply be a "first charge" - nothing to worry about yet...
    Use it for a few days, give your iPod an opportunity to charge a few times.
    If you still have the same question after a week, give AppleCare a call, or talk to a "genius"
     
  3. Reno Raines macrumors 6502a

    Joined:
    Jul 19, 2015
    #3
    My 6g does that and my 5g also would never show the plug icon that said 100%. I have to use an app to tell me that.
     
  4. JoeShades thread starter macrumors 6502a

    Joined:
    Sep 1, 2010
    Location:
    Williamstown, NJ
    #4
    Stupid for apple to remove the plug icon as an indicator, I just downloaded an app , battery HD + and it says 100% charged.......but then when i unplugged the charger it says 99% :confused:
     
  5. JoeShades thread starter macrumors 6502a

    Joined:
    Sep 1, 2010
    Location:
    Williamstown, NJ
    #5
    Well i got 5 hours from the battery . Recharging to 100% took less than 90 minutes, that seems way too quick
     

Share This Page