Possible fix for iCloud PUSH mail...

Discussion in 'iPhone' started by insocal, Nov 3, 2011.

  1. insocal macrumors regular

    Joined:
    Jul 31, 2007
    #1
    Just got off of yet another Chat with Apple Support. The rep I spoke with had me do the following...

    Go into Settings>Mail, Contacts, Calendars>Advanced...turn ALL to FETCH
    Go into Settings>Mail, Contacts, Calendars>Fetch New Data...turn Push OFF.

    Reboot Phone...Home/Power button held down at the same time.

    Go back into Settings>Mail, Contacts, Calendars>Fetch New Data...turn Push ON. Leave Advanced set to Fetch.

    Sent myself a Test e-mail from my MacBook Pro Mac Mail withOUT Mail open OR running in the background on the iPhone.

    The message arrived almost immediately.

    This is the first time I've received a 'solution' from ANYONE. I'm really hoping it's not a temporary fix.

    The rep's name was Jason and he told me he set up his iPhone the same way. Also told me I could take the credit when posting in the forums to help others but I assured him I wouldn't. :)

    Hope it works for all of us having trouble since moving over from MobileMe to iCloud.
     
  2. canesalato macrumors 6502a

    canesalato

    Joined:
    Jan 31, 2010
    #2
    It seems to work!!! :) thanks!
    ...will let you know if it stops working, let's hope it won't
     
  3. Beauborg macrumors newbie

    Joined:
    Oct 26, 2011
    #3
    I've just tried this. Unfortunately, it hasn't worked for me. I sent an email from a different phone to my me.com account, and I only received it once I actually went into the mail app - even though I waited half an hour. I wonder why push isn't working.
     
  4. SanjeevRana macrumors 6502a

    SanjeevRana

    Joined:
    Aug 2, 2011
    #4
    Well one of the bugs to be fixed in 5.0.1 seems to be iCloud Push

    Working flawlessly now ... will monitor more !
     
  5. HellDiverUK macrumors 6502

    Joined:
    Oct 24, 2009
    Location:
    Belfast, UK
    #5
    Solution to a problem that most people don't have?

    iCloud push mail has worked 100% for me since 5.0 came out. :confused:
     
  6. TraceyS/FL macrumors 68040

    Joined:
    Jan 11, 2007
    Location:
    North Central Florida
    #6
    Until it works for 5-7 days, I wouldn't declare it fixed. Under 4.2 & 4.3 mine has had a problem and works for anywhere from 1-5 days, then starts it cycle of working and then not.

    I'm 99% sure the bug I have on my iPad with push and MobileMe (which apple is aware of) is the same problem since it was deemed an iOS problem not a MobileMe one.

    Please keep us posted on how it goes!
     
  7. bandcamp macrumors newbie

    bandcamp

    Joined:
    Sep 2, 2009
    Location:
    Cardiff, UK
    #7
    I've just updated to iOS 5.0.1, and push emails are working perfectly (for now) on both my iPhone 3GS, and iPad 2. Didn't work before unless the app was running in the background, but everything seems to be fine. Surprised Apple didn't mention the fix in the release notes for 5.0.1... Anyway, not bothered now, iOS 5 and iCloud work as they should do.
     
  8. Oecher macrumors newbie

    Joined:
    Jan 4, 2009
    #8
    5.0.1 und Push still not working: Possible fix

    Just updated to 5.0.1 and Push still not working. However doing everything insocal suggested, then setting everything everywhere to push again - even in Settings>Mail, Contacts, Calendars>Push>Advanced - did the job. :) Maybe the reset was necessary to make things right.

    Hope this helps someone who faces the same problem.
     

Share This Page