Possible message bug?

Discussion in 'iOS 7' started by vegastime, Aug 8, 2013.

  1. vegastime macrumors regular

    Joined:
    Jun 14, 2010
    Location:
    Virginia
    #1
    I have a contact that just switched to Android. I cannot send him a text using Beta 5, as it appears to be trying to send an iMessage, instead of a text message. I can receive his texts fine. No problem sending texts with IOS6. I even tried deleting him as a contact.

    Anybody else experience this?
     
  2. adamgbiggs macrumors regular

    adamgbiggs

    Joined:
    Jun 28, 2013
    Location:
    UK
    #2
    This has happened to me in the past with one contact, think it was when iOS 5 just went public so not sure if it's a iOS 7 bug or if it's just one of those things that happens, can't remember how I sorted it but it did finally revert to text instead if iMessage.

    Adam.
     
  3. SakuraSuki macrumors 6502

    Joined:
    Jul 18, 2013
    #3
    Go to the contact of this person, change iPhone beside this person's phone number to mobile. This will stop iMessage trying to send him through iMessage
     
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #4
    Your friend didn't turn iMessage off before swapping phones. Ios6 defaults to text after a certain amount of time or failed attempts. Ios7 does not as you have the option to enable this in settings > messages.
     
  5. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #5
    Has your friend disabled iMessage on his iPhone before moving over to Android?

    ----------

    Now that would seem like a bug, or an oversight of some sort.
     
  6. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #6
    How's it a bug? You still get the option to send as text as well as warning it's not sent.
     
  7. Kohkane macrumors 6502a

    Joined:
    Jun 10, 2008
    #7
    In iOS7 after a certain amount of attempts it still sends at sms, they didn't remove this.
     
  8. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #8
    What if you don't want it to be sent as a text message automatically if iMessage fails? I've had that happen a few times already, but have no way to turn it off now it seems.
     
  9. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #9
    Your both miss understanding what I am saying. In ios6 the option to auto send as text was enabled by default. In ios7 the default is off.

    ----------

    Clearly not what I said
     
  10. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #10
    You are correct, it seems that I misread/misunderstood your original reply.
     
  11. vegastime thread starter macrumors regular

    Joined:
    Jun 14, 2010
    Location:
    Virginia
    #11
    Thanks, but I already have mobile next to his name, so that is not it.

    ----------

    Thanks!

    That was the problem. Was not aware of this change/setting.

    No bug, after all.
     
  12. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #12
    i dont think its an iOS 7 bug, but more of an iMessage/Android issue. i think it stems from the apple network/servers recognizing his number as an iMessage number and is attempting to continue to send it as such. i had a similar issue with my iMessage reactivating on my verizon SIM after i got home from Iceland and was using a prepaid SIM over there. I think he should reactivate his iPhone, confirm iMessage works from his number, then deactivate iMessage properly and remove his phone number from the list.
     
  13. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #13
    The work around has always been to turn iMessage off before removing your sim or swapping phones. If this step is missed then the servers will just assume your phone is switched off and poll the iMessages.
     
  14. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #14
    Good to know. Thanks.
     

Share This Page